Acer Aspire E17 with Nvidia Optimus

Hello!

Can somebody show me a right method how can I setup my Nvidia Optimus “supported” Acer Aspire E17 E5-773G-52PB to use minimum the Nvidia card?
Sorry, when I bought this notebook I doesn’t from the two different video card (even two differnt manufacturer) are inside. On the machine and in advertisements of the shop where I bought everywhere was mention only one card.Sorry so far I couldn’t found from this notebook a full and correct specification nowhere anything.

As far as I know, the Optimus systems do not have discrete (dedicated) Nvidia graphics, just an Nvidia GPU that uses the video memory of the Intel GPU. So I can use the Intel GPU alone for power savings, or Intel + Nvidia GPU together for the faster rendering if the software supports it, but not Nvidia alone. But I’m not sure in this! For me the power saving is not important! I would like to use only the notebook’s monitor.

I would like to use the two card together or the NVIDIA card alone.Sorry, I cannot switch off either GPU off in the laptop’s BIOS. I’m meaning on a BIOS update (maybe in an updated BIOS I will can switch off either GPU), but I need for the legacy BIOS option also in the future (I’m using some live and other not windows distros).A disease of the Acer that the legacy BIOS option missing from the new BIOS versions (they makes only windows notebooks).
Maybe if somebody can offer me an other solution to switch off either GPU please write it down.
Now I can du it with this script:

% fetch https://people.freebsd.org/~xmj/turn_off_gpu.sh
% make -C /usr/ports/sysutils/acpi_call install clean
% vim turn_off_gpu.sh # read it before executing!
% sh turn_off_gpu.sh # as root user

I already tried a lot of different method from the network so far without any luck.I need an not port collection method.

My system:

uname -a
FreeBSD host 12.0-CURRENT FreeBSD 12.0-CURRENT #30 a7f7424(drm-next): Tue Feb 21 23:42:39 UTC 2017 root@gauntlet:/usr/obj/usr/src/sys/GENERIC amd64

My cards:

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07)

lspci | grep 3D
01:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 940M] (rev a2)

pciconf -lvb
vgapci0@pci0:0:2:0: class=0x030000 card=0x09851025 chip=0x19168086 rev=0x07 hdr=0x00
vendor = ‘Intel Corporation’
device = ‘HD Graphics 520’
class = display
subclass = VGA
vgapci1@pci0:1:0:0: class=0x030200 card=0x09851025 chip=0x134710de rev=0xa2 hdr=0x00
vendor = ‘NVIDIA Corporation’
device = ‘GM108M [GeForce 940M]’
class = display
subclass = 3D

My monitor:

xdpyinfo | grep -B1 dot
VendorName “AUO”
ModelName “B173HDN01,1”
dimensions: 1920x1080 pixels (508x285 millimeters)
resolution: 96x96 dots per inch
NOT DPMS SUPPORT!

nvidia-xconfig --query-gpu-info
Number of GPUs: 1
GPU #0:
Name : GeForce 940M
PCI BusID : PCI:1:0:0
Number of Display Devices: 0

xrandr program version 1.5.0

xrandr --listproviders
Providers: number : 1
Provider 0: id: 0x46 cap: 0x2, Sink Output crtcs: 3 outputs: 4 associated providers: 0 name:modesetting

xrandr -q | grep conn
eDP-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 381mm x 214mm
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)

pkg info nvidia-driver
nvidia-driver-375.26_1
Name : nvidia-driver
Version : 375.26_1
Installed on : Thu Mar 9 11:23:11 2017 CET
Origin : x11/nvidia-driver
Architecture : freebsd:12:x86:64
Prefix : /usr/local
Categories : x11 kld
Licenses : NVIDIA
Maintainer : danfe@FreeBSD.org

Xorg -version
X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD 12.0-CURRENT amd64

Last time I tried these:

https://wiki.freebsd.org/OptimusVideoSupport this is a little bit “rough” :-)
https://gist.github.com/dch/992f445b9673aa49325d

but I couldn’t found nowhere “nvidia-driver-optimus”.

My system use BSD boot loader not GRUB.

I’m using legacy BIOS mode.