[Acer Nitro 5] Linux 20.04.03 Nvidia 1050Ti 470.74 stuck in black screen with terminal cursor (underscore) after waking up from being suspended

Hi, I have tried various solutions to fix this problem, but no luck.

I decided to switch from Windows 10 to Ubuntu, and noticed if I try to suspend the device (put to sleep), waking up makes the system become unresponsive, with black screen and blinking underscore on top left.

Tried multiple driver versions, nothing solves my issue. In other cases, GPU seems to work fine.

Please help, I’m new to Linux and seem to be pretty lost already.nvidia-bug-report.log.gz (323.2 KB)

EDIT: Trying to understand the problem, basically what happens is:

  1. I suspend the device

  2. Try to wake up again

  3. See black screen with blinking underscore (console cursor)

  4. After a while, this error message comes up

  5. Nothing else, have to REISUB

During 3-5 steps can’t do anything much to escape this. Try to Ctrl+Alt F1-F7, system completely freezes (underscore stops blinking)

EDIT2: Removed “quiet splash” from GRUB_CMDLINE_LINUX_DEFAULT=, another error message popped-up: Imgur: The magic of the Internet

EDIT3: Completely uninstalling nvidia drivers using these instructions (unity - How can I uninstall a nvidia driver completely ? - Ask Ubuntu) allow me to suspend safely, without getting stuck in a black screen. Leaving me only with Intel Graphics. But it’s not an ideal solution because I still need my NVidia GPU for gaming.

For a test, please install the 390 legacy driver using Software&Updates application and check if the same occurs with it.

Please also check if this applies:
NB: you need to run
sudo update-initramfs -u
after adding the udev rule.

Thank you! I spent my whole day trying to fix this issue, got my head spinning already (I thought I did try 390 and it seemed not to work). Probably didn’t uninstall other drivers fully first, that’s why.

Does Vulkan work with 390? Tried to test a game (Dota2) which supports Vulkan, but upon launch, gives an error message window saying “CreateSwapChain(): Unable to query the size of supported swapchain format.” But the game launches fine using OpenGL. Is it possible to fix the Vulkan issue now?

Using the 390 driver isn’t the solution but merely a test whether there’s a general issue with your notebook or just the newer nvidia drivers and their advanced power-management features. 390 only supports vulkan 1.0.
Please upgrade to v470/495 again, then try creating the udev rule from my previous post and check if that fixes the problem.

Man, thank you! Everything worked, I suspected it was something to do with power management, just didn’t know how to change it. You definitely made my day and I’m so excited to continue exploring Linux!!

One last question about 470 vs 495 drivers: I reckon 470 is more stable (for my system) currently than 495 on Linux, since it’s the maximum version available in Ubuntu’s “Additional Drivers” section? Or is it still better if I try to upgrade to 495?

Many thanks again, and have a wonderful day.

Upgrading to bleeding edge drivers is only needed if problems with games occur that are fixed in beta/feature branch drivers. Or you’re interested in experimenting with new features.
For those cases, there’s the graphics drivers ppa:
After adding that, the new drivers are available to choose in Software&Updates.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.