ADB USB debugging not working with NVIDIA Shield TV (2017) firmware 6.0

So I’m not sure if it’s related to the new firmware, but USB ADB debugging used to work just fine with this Shield and the same USB cable and same Windows PC, back on 4.0 firmware I think.

Here is what I’ve tried:

  1. Enable developer options
  2. Enable USB debugging (and revoke authorizations)
  3. Plugged USB cable into slot furthest from the HDMI port
  4. Tried to update the drivers with https://developer.nvidia.com/gameworksdownload#?search=SHIELD%20Family%20Windows%20USB

These are the errors I’m seeing in Windows 10:

  1. “USB device not recognized”
  2. “The last USB device you connected to this computer malfunctioned and Windows does not recognize it”
  3. In the Device Manager I see a “USB composite device” with a yellow triangle but I can’t update the driver with the one I downloaded above. These are the detailed errors:

This device cannot start. (Code 10)
A device which does not exist was specified.

Device USB\VID_0955&PID_B43D\0324216275489 had a problem starting.
Driver Name: usb.inf
Class Guid: {36FC9E60-C465-11CF-8056-444553540000}
Service: usbccgp
Lower Filters:
Upper Filters:
Problem: 0xA
Problem Status: 0xC000000E

Device USB\VID_0955&PID_B43D\0324216275489 was configured.
Driver Name: usb.inf
Class Guid: {36FC9E60-C465-11CF-8056-444553540000}
Driver Date: 06/21/2006
Driver Version: 10.0.15063.674
Driver Provider: Microsoft
Driver Section: Composite.Dev.NT
Driver Rank: 0xFF2003
Matching Device Id: USB\COMPOSITE
Outranked Drivers:
Device Updated: false
Parent Device: USB\ROOT_HUB30\4&1148bc98&0&0

Device USB\VID_0955&PID_B43D\0324216275489 could not be migrated.
Last Device Instance Id: USB\VID_0781&PID_5580\AA010801131656321678
Class Guid: {36FC9E60-C465-11CF-8056-444553540000}
Location Path: ACPI(SB)#ACPI(PCI0)#ACPI(XHC_)#ACPI(RHUB)#ACPI(SS03)
Migration Rank: 0xF000FFFFFFFF0022
Present: false
Status: 0xC0000719

OREO Problems…

updated firmware using fastboot via a usb cable…

worked fine and i kept my apps but lost root and the mod that made my Mele remote work.

flashed the dev version of the same ROM

it failed during the system.img flash…

Now the box is bricked and it is not recognised as a USB device so i can’t unbrick.

The recovery and boot .img’s flashed fine but i can’t get in to recovery by pressing A+B.

So i’m basically i’m fu**ed.
(all for a poxy home screen revamp)