Add MPEG4 format for RTSP on sink

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
• DeepStream Version
• JetPack Version (valid for Jetson only)
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

  • Jetson AGX Xavier
  • DeepStream SDK
  • JetPack 4.6
  • TensorRT 8.0

I’m testing to add mpeg4 for RTSP on sink and I run it on deepstream-app.

I modified ‘deepstream_source_bin.c’ as follows :

And sink plug-in was set as it :
image

The local display and application have no issue and it works.
But it has no display when I tried to access RTSP stream through VLC Mediaplayer on my Laptop.

The RTSP access has no issue with H.264 and H.265.
But MPEG-4 is no display output on VLC Mediaplayer with the same process.

Does anyone have an idea?


And which one is the correct option for MPEG-4 rtppay?

Sorry for the late response, is this still an issue to support? Thanks

Hi,
Do you use software encoder to encode to MPEG4 stream? Xavier does not have MPEG4 hardware encoder. For better performance, we would suggest encode to h264 or h265.

FYI, hardware encoders are listed in developer guide

Yes, It still has a issue.
This work is stuck.

Actually, one of our co-operation company wants to use this codec.
I aleready know hardware doesn’t support MPEG4 and software uses cpu or gpu.
So, I edited code like that.
I can use MPEG4 when i select software on the sink option.
You can see the code in the question.
Anyway, their requirment need to use MPEG4,
This is the why I am trying to do it.

Hi,
We are able to set up RTSP server on Xavier through test-launch:

$ ./test-launch "videotestsrc ! avenc_mpeg4 ! rtpmp4vpay name=pay0 pt=96"

Add decode it through VLC player on host PC. Please add avenc_mpeg4 to create_udpsink_bin() for a try.

FYR, there is guidance of running RTSP streaming in Jetson Nano FAQ

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.