Added tracker node (tracker) print format error

Please provide complete information as applicable to your setup.
• Hardware Platform (Jetson / GPU) [GeForce RTX 3070 Ti]
• DeepStream Version version 6.0.0
• JetPack Version (valid for Jetson only)
• TensorRT Version TensorRT-
• NVIDIA GPU Driver Version (valid for GPU only) CUDA Version: 11.5
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

2022-09-07 16:18:20,968 INFO gstname=audio/x-raw
2022-09-07 16:18:20,968 INFO gstname=audio/x-raw

Added tracker node (tracker) print format error


!![Exception] [NvMOTContext::processFrame()] motFrame->bufferList[i]->colorFormat != m_Config.perTransformBatchConfig[i].colorFormat
An exception occurred. [NvMOTContext::processFrame()] motFrame->bufferList[i]->colorFormat != m_Config.perTransformBatchConfig[i].colorFormat

I tried to add nvvideoconvert in front of the nvtracker plugin, but the same error was reported

# Use convertor to convert
nvvidconv4 = Gst.ElementFactory.make(“nvvideoconvert”, “nvvidconv4”)
if not nvvidconv4:
logger.error(" Unable to create nvvidconv4 \n")
# Create a caps filter
filter4 = Gst.ElementFactory.make(“capsfilter”, “filter4”)
if not filter4:
logger.error(" Unable to get the caps filter4 \n")
filter4.set_property(“caps”, Gst.Caps.from_string(“video/x-raw(memory:NVMM), format=NV12”))

There is no update from you for a period, assuming this is not an issue anymore.
Hence we are closing this topic. If need further support, please open a new one.

Could you attach your pipeline graph by refering the link below?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.