Adding an unsupported display

Hello, I am attempting to attach a generic HDMI panel to my Nano. The Nano is working fine and displays normally on my actual monitors, and the display is working, but only on windows machines.

The display requires portrait mode 50 hz output at 1440x2560, CVT. Since the Nano only has one HDMI port, I can’t have the display connected at the same time I’m editing settings (because I’d be editing blind) so how do I go about adding that mode?

Update: Using an EDID tool I found out the display is incorrectly reporting itself as a 1440x2560 60hz display, and not the correct 1440x2560 50hz. How do I get X to ignore this info specifically for this display?

There is no way to ignore. Tegra display driver only accepts modes from EDID. Adding mode is also not acceptable.

Thus, actually you should provide a correct EDID but not a mode.