Address already in use. Jetpack is unable to find IP address error

Error Message:

Flashing comp1eted

[147.4357] Coldbooting the device
[ 147.4378 ] tegradevflash7v2 --reboot Coldboot
[ 147.4391 ] Bootloader version 01.00.0000
** The target t186ref has been flashed successfully. *“
Reset the board to boot from internal eMMC

1
Finished Flashing 05

Determining the IP address of target...
nc: Address a1ready in use

JetPack is unable to determine the IP address of the Jetson Developer Kit
Failure to run bash command “timeout 180 nc .1 33338” because of error: exit status 1, nc: Address a1ready in use
P1ease se1ect which action do you want:

1. Retry

2. Manua11y enter IP address

Your option is <1/2>:

Setup:

Host Machine Ubuntu 16 OS(Not VM)
Jetpack 3.1
Jetson TX2
Router Netgear

Connection:
Host machine and Jetson are in same subnet.
i.e.Jetson and Host PC are connected to same router directly via LAN.

After following the setup, installation stucks at mentioned error.
Also, if Jetson is connected to monitor, not able to see anything on screen. So not able to find IP manually.
Also, tried an mobile application Network IP scanner, Jetson isn’t there in the list of connected devices.
Also, tried router login, Jetson wasnt there is connected devices.
Jetson’s LAN port is not blinking green.

Trying 2.Manually enter IP address exits the process.

Need urgent help.
Any suggestions?
Thank you,
Komal

"Also, if Jetson is connected to monitor, not able to see anything on screen. So not able to find IP manually. " -> It is weird that tegra is unable to boot up after flashing. Do you have UART debugger to dump the console log?

No.
I dont have UART right now.

Want to mention:

The Jetson was flashed once successfully with Jetpack 3.2
Now I’m trying 3.1.

If this makes any diffrence.

pharatekomal,

I found the problem. Jetpack3.1 does not support ubuntu16.

But I have done successful installation once with above setup.

You have to make sure that tegra is able to boot up successfully.

Any way to do that?

You can always use your router’s logs (or watch “dmesg --follow” as the Jetson boots if your PC host is the router) to find the address of the Jetson. No need to log in to the Jetson.

You can always flash on command line, and then run JetPack later to add packages (you’d just uncheck the flash option in JetPack, but unless the Jetson freshly flashed from JetPack you’ll always need to manually enter the IP address). The “Documents” from the L4T page explain command line flash (which does not need any specific Linux distribution to use…JetPack front end is what requires a specific Ubuntu version), but here’s a description based on R28.2 (you can now use R28.2.1 though):
https://devtalk.nvidia.com/default/topic/1031769/jetson-tx2/unable-install-any-jetpacks-jetson-tx2/post/5249710/#5249710

The R28.2.1 download page is:
https://developer.nvidia.com/embedded/linux-tegra

If you choose to install on command line you need the driver package and the sample rootfs. One of the things the JetPack front end does is to download these for you, but command line has fewer requirements, so this is your best choice when debugging a flash.

Moreover, ip addresses of Host PC and jetson can be explicitly declared in the router configuration if you add static ip addresses for devices. To do that you will need to know mac addresses of the devices and then you will be able to assign manually ip addresses to the mac addresses in a way they will not overlap.

Hi,
As I mentioned, Jetson was flashed previously with Jetpack 3.2.
And now I was trying to flash it with 3.1.
And I was getting above mentioned errors.
So I tried flashing 3.2 again and it worked.

So I have a doubt-
Is there any issue because of pre-installed higher version. Different memory partitions issue etc?
Or flashing any version of jetpack supported on Jetson should work?

IP address issue was - OS wasn’t flashed right. So ethernet port didn’t blink. May be drivers weren’t installed properly. I had no UART cable to check what is the bug in OS flashing. But yes, the issue was with OS flashing itself

pharatekomal,

It sounds weird to me. However, I still suspect the ubuntu16 in your first comment since Jetpack3.1 is not verified on 16.04 host at all. Jetpack3.2 starts to support 16.04.

Okay.
I had the same doubt to. But I have done flashing with Ubuntu 16 + Jetpack 3.1 successfully. So thought maybe it will work.

I come across same problem, and finally I found that I choose the wrong Network Adapter.