Adjusting Overscan for a TV display

The TV that I am using as a display on the Jetson TX1 Development board doesn’t have any overscan adjustments available on the TV itself. I have previously been able to find a workaround for this issue for the Raspberry Pi, but it apparently isn’t as common an issue with the Jetson. I am able to boot up into the GUI but the menu bar and the task bar are both cut off completely making work nearly impossible. How would I go about correcting the overscan?

Hi,

I think you could use xrandr.

Please try

export DISPLAY=:0
xrandr

---you will see something like below--

DP-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 310mm x 170mm panning 1950x1080+0+0
   1920x1080     60.05*+
---------------------------
xrandr --output DP-0 --set underscan on

If you hit any errors, you may try xrandr --output --transform

After much fiddling around with xrandr, I have managed to shrink the output to a manageable size by changing my borders and decreasing the size of the framebuffer to 1080x601. Doing this, makes it pan up and down by one pixel, but if I decrease the framebuffer by that one extra pixel, the whole screen reverts back to extreme overscan. For your reference, the output from typing xrandr is:

Screen 0: minimum 8 x 8, current 1080 x 601, maximum 16384 x 16384
HDMI-0 connected primary 1080x600+0+0 (normal left inverted right x axis y axis) 0mm x 0mm panning 1080x601+0+0
   1280x720      60.00*+  59.94  
   1920x1080     61.25    60.05  
   1440x480      62.69    60.05  
   720x480       59.94  
   640x480       59.94

xrandr --prop yields:

Screen 0: minimum 8 x 8, current 1080 x 601, maximum 16384 x 16384
HDMI-0 connected primary 1080x600+0+1 (normal left inverted right x axis y axis) 0mm x 0mm panning 1080x601+0+0
	EDID: 
		00ffffffffffff0019c9010000000000
		00100103800000780aebbca654469824
		10484b00000001010101010101010101
		010101010101011d007251d01e206e28
		550010090000001e8c0ad08a20e02d10
		103e9600100900000018000000fc0046
		554e41492054560a20202020000000fd
		003b3d0f2e08000a202020202020011c
		02031a70470403020506070123090707
		8301000065030c0010008c0ad08a20e0
		2d10103e9600040300000018011d8018
		711c1620582c250010090000009e8c0a
		a01451f01600267c4300040300000098
		8c0aa01451f01600267c430010090000
		00980000000000000000000000000000
		00000000000000000000000000000067
	TegraOverlayBlendmode: Opaque 
		supported: Opaque, SourceAlphaBlend, PremultSourceAlphaBlend
	TegraOverlayPriority: 255 
		range: (0, 255)
	BorderDimensions: 4 
		supported: 4
	Border: 100 60 100 60 
		range: (0, 65535)
	SignalFormat: TMDS 
		supported: TMDS
	ConnectorType: HDMI 
   1280x720      60.00*+  59.94  
   1920x1080     61.25    60.05  
   1440x480      62.69    60.05  
   720x480       59.94  
   640x480       59.94

For now, this is working. Hopefully it won’t revert back to the original settings on reboot.