After the OTA upgrade, the eth0 network card (with lspci) is lost

I upgraded NX Development Suite from 32.4.3 to 32.5 through Ota. After upgrading, I found that the network card had no information and the lspci was empty

That sounds new issue.

What is the card you are using? And just an experiment, will you see this card if you flash with 32.5 but not OTA to 32.5?

it’s on board network card.
it works well on 32.5 or 32.5.1 on NX’s downloaded imageimg.

Just want to confirm: do you upgrade to rel-32.5.1 or rel-32.5? You can check /etc/nv_tegra_release.

ota Upgrade to 32.5.1

Can you share the full dmesg?

I replied to N before,I tried again,Reply y seems to be working well.

If apt prompts you to choose a configuration file, reply Y for yes (to use the NVIDIA updated version of the file).

Thank you for your reply.

Are the following errors caused by my custom DTB? I’ve skipped these problems and upgraded to 32.5.1. Won’t these errors make any difference.

sudo apt upgrade

Setting up nvidia-l4t-bootloader (32.5.1-20210614115015) ...
ERROR. Unsupported board ID: .
Cannot install bootloader package. Exiting...
Starting bootloader post-install procedure.
rootfs AB is not enabled.
ERROR. Procedure for bl_update_payload update FAILED.
Cannot install package. Exiting...
dpkg: error processing package nvidia-l4t-bootloader (--configure):
` installed nvidia-l4t-bootloader package post-installation script subprocess returned error exit status 1`
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I am not sure what you are talking about.

In the beginning of this topic, you said it is development suite. It should be devkit, I guess.

But now you have customize dtb. Why do you need a custom dtb on devkit? What change did you make?

You should tell all these patches and changes from the beginning. And even the environment info.

Sorry, I didn’t make it clear at the beginning. I encountered two problems, both in the OTA upgrade

  1. This problem has been solved. I upgraded on the NX development kit. Later, I found that my operation was wrong. (I should choose y in the upgrade instead of the default n).
  2. Another is the OTA upgrade on the customized board. I find that some interfaces cannot be used after the upgrade. Do I need to recompile the new DTB with the new version of l4t? After compiling the new DTB, how can I update it to NX device remotely

By default the OTA update has the NVIDIA related components in the apt source list.

Which means when you run apt upgrade, it will install the jetpack again. It will install the default dtb of jetpack to your board again.

If you know how dtb and kernel work, you would know that custom board requires a custom dtb. Which means OTA update will make your custom board fail to work.

If you just want to do the upgrade but not installing jetpack again, remove the nvidia source from the apt source list (etc/apt/…)

Actually, this part should be customized by the custom board vendor. For example, if vendor has their own dtb, they should create a new debian package which has their dtb file inside.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.