AGX Orin not recognized in any way of connecting it

Finally haha. Thank you for your help so far. I have no idea about the specifics of this, so thank you for bearing with me.

Unfortunately, it seems the file system got corrupted.

Did you remember what was done in the last time you can still operate it?

But no matter what you did, you can only recover it by reflashing the board with sdkmanager now.

Please prepare a native x86 ubuntu 18.04 or 20.04 host and install sdkmanager on it. Put the board into recovery mode and then start flash process.

The last command that I wrote while it was working was I ran the two update lines from the “start here” install manual to update the version. Nothing happened so I ran “sudo reboot”. That’s the last thing I was able to run. I have 20.04 setup and sdk manager installed. I will see if I can get it to reflash this time as it didn’t work before.

Okay, I’m back. I setup the sdk manager and have got it to recognize the board, but for some reason, when I go to install the Target Components, I either get “This board is in a bad state” message, or cannot connect to board. I have tried both press and hold middle/left and middle/right. Neither worked. It did get all the way to 97% complete and then failed. I saw someone used flash.sh for their TX2, but I am unsure if that’s what I should do and what to change for the AGX Orin.

flash.sh is equal to how sdkmanager flashes boards. Sdkm just wraps those tools in a GUI. The service in the background is still flash.sh.

Check your ~/nvidia directory on your host machine and it will lead you to flash.sh.

Please follow the developer guide → quick start section to know how to use flash.sh.

If you don’t know how to find developer guide, search “l4t archive” in google search.

Here is my log for the manual flash of the board. I’m still not sure what I am doing wrong.

flash log (60.6 KB)

Is this a orin devkit carrier board or some custom board?

It is an orin 64gb developer kit I bought off of Amazon.

please dump the serial console log during flash from the micro usb port.

Please be aware that this is again micro usb port. Not type C port.

As another post is telling, please do not use VM host. Use native ubuntu.

Okay, well I didn’t know that. I said that I was using a VM 3 days ago and you never referenced it. Also, I have to use a VM. I do not have an Ubuntu based computer. You’re saying there is no way to work with this board without an actual Ubuntu OS? If so, then I bought a $2,200 brick…

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.