AGX suddenly turns off

AGX turns on without any problem, however, after long operations or even, on a few occasions it suddenly turns off and on inmediatly (like if there was a electrical short). The AGX is not operational all the time, there is no pattern that determines when the failure will occur.
We tested out another backplane (Devkit) that was properly working and the same symptoms appear to be happening.
What can we do? Can we get another one for guarantee?

Is there any application running on device?
What’s the JetPack version you used?
We need more info to triage if that’s the HW problem as you mentioned the same symptom happened at another device as well.

Hi,

I seem to have the same problem.

As long as some processing is happening on the GPU, it stays on. But if it is just sitting idle even with idling containers, it just turns off.

It there a setting to control that behavior?

Thanks
Simon Glet

Infos:
R34 (release), REVISION: 1.1, GCID: 30414990, BOARD: t186ref, EABI: aarch64, DATE: Tue May 17 04:20:55 UTC 2022
Linux ubuntu 5.10.65-tegra #1 SMP PREEMPT Mon May 16 20:58:07 PDT 2022 aarch64 aarch64 aarch64 GNU/Linux

Syslog at automatic shutdown:
Sep 19 08:59:19 ubuntu gnome-session-binary[2591]: Entering running state
Sep 19 08:59:19 ubuntu xbrlapi.desktop[2806]: openConnection: connect: No such file or directory
Sep 19 08:59:19 ubuntu xbrlapi.desktop[2806]: cannot connect to braille devices daemon brltty at :0
Sep 19 08:59:19 ubuntu gsd-media-keys[2727]: Failed to grab accelerator for keybinding settings:playback-random
Sep 19 08:59:19 ubuntu gsd-media-keys[2727]: Failed to grab accelerator for keybinding settings:playback-repeat
Sep 19 08:59:19 ubuntu gsd-media-keys[2727]: Failed to grab accelerator for keybinding settings:hibernate
Sep 19 08:59:19 ubuntu gsd-media-keys[2727]: Failed to grab accelerator for keybinding settings:rfkill
Sep 19 08:59:19 ubuntu gnome-shell[2639]: JS WARNING: [resource:///org/gnome/shell/ui/layout.js 24]: reference to undefined property “MetaWindowX11”
Sep 19 08:59:20 ubuntu gnome-shell[2639]: cr_parser_new_from_buf: assertion ‘a_buf && a_len’ failed
Sep 19 08:59:20 ubuntu gnome-shell[2639]: cr_declaration_parse_list_from_buf: assertion ‘parser’ failed
Sep 19 08:59:20 ubuntu dbus-daemon[900]: [system] Activating via systemd: service name=‘net.reactivated.Fprint’ unit=‘fprintd.service’ requested by ‘:1.65’ (uid=124 pid=2639 comm="/usr/bin/gnome-shell ")
Sep 19 08:59:20 ubuntu systemd[1]: Starting Fingerprint Authentication Daemon…
Sep 19 08:59:20 ubuntu dbus-daemon[900]: [system] Successfully activated service ‘net.reactivated.Fprint’
Sep 19 08:59:20 ubuntu systemd[1]: Started Fingerprint Authentication Daemon.
Sep 19 08:59:20 ubuntu gnome-shell[2639]: Getting invalid resource scale property
Sep 19 08:59:20 ubuntu gnome-shell[2639]: cr_parser_new_from_buf: assertion ‘a_buf && a_len’ failed
Sep 19 08:59:20 ubuntu gnome-shell[2639]: cr_declaration_parse_list_from_buf: assertion ‘parser’ failed
Sep 19 08:59:20 ubuntu gnome-shell[2639]: cr_parser_new_from_buf: assertion ‘a_buf && a_len’ failed
Sep 19 08:59:20 ubuntu gnome-shell[2639]: cr_declaration_parse_list_from_buf: assertion ‘parser’ failed
Sep 19 08:59:20 ubuntu gnome-shell[2639]: Registering session with GDM
Sep 19 08:59:21 ubuntu kernel: [ 38.750021] nvgpu: 17000000.gv11b nvgpu_gsp_stress_test_halt:252 [INFO] GSP stress test not loaded
Sep 19 08:59:23 ubuntu kernel: [ 39.904174] vdd-3v3-cvb: disabling
Sep 19 08:59:23 ubuntu kernel: [ 39.904240] vdd-1v8-cvb: disabling
Sep 19 08:59:23 ubuntu kernel: [ 39.904250] vdd-epb-1v0: disabling
Sep 19 08:59:23 ubuntu kernel: [ 39.904258] vdd-sata-1v5: disabling
Sep 19 08:59:23 ubuntu kernel: [ 39.904265] vdd-1v8-slt: disabling
Sep 19 08:59:23 ubuntu kernel: [ 39.904272] vdd-3v3-slt: disabling
Sep 19 08:59:23 ubuntu kernel: [ 39.904290] vdd-1v8-sd: disabling
Sep 19 08:59:23 ubuntu kernel: [ 39.904342] vdd-sdmmc1-sw: disabling
Sep 19 08:59:23 ubuntu kernel: [ 39.904352] avdd-cam-2v8: disabling
Sep 19 08:59:23 ubuntu kernel: [ 39.904361] vdd_sys_en: disabling
Sep 19 08:59:23 ubuntu kernel: [ 39.904370] vdd-3v3-pcie: disabling
Sep 19 08:59:23 ubuntu kernel: [ 39.904377] vdd-12v-pcie: disabling

We need more information to have suggestions, not sure if you have try with the NVPMoel setting to have the power and performance balance.
For more issue, please help to open a new topic. Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.