AGX Xavier - How to install remote tool

I bought AGX Xavier.
I used to use remote on different servers, VM (Linux, win,…) from my computer Windows 10.
I really don’t find any way of how to install remote tool on AGX Xavier.
I am very surprised to see how difficult it is to install one. For the moment I am quite on it and I did not expect it. I try VNC… Team…, so much, but nothing works correctly.
I’ve wasted so much time trying, I’m discouraged.
For me, it is a minimum of being able to use it in remote, for the moment it is really a disappointment.

Please, could you help me by advising me which system works correctly.
Where could I found a tutorial advisor by NVidia.

Thanks a lot for helping.

I use mine through SSH; granted, my host computer is linux, but even if you’re on windows you should be able to use ssh-tools like putty to log in from a windows machine.

Thanks for your answer. You right, it’s easy to use with SSH and Putty.
But I installed AGX at home, and when I’m at work or on travel, I would like to access over Remote Desktop.
For some stuff or dev, it’s easier. You really not have any idea with VNC / TeamV / … not working correctly as standard Ubuntu distribution ?


Huh. I’m more of a command-line guy myself, and don’t use VNC all that often - but the jetson does seen to have a pretty much default Ubuntu install on it, so any regular vnc method (eg, tigervnc) “should” just work … and just for my own sanity, I just tried it and it does indeed seem to work.

Here’s what I did (largely following this page that “extensive literature research” - ie, google - pointed me to:

First, on my jetson agx (named, fittingly, “jetson”):
wald@jetson: sudo apt install tigervnc-standalone-server
wald@jetson: mkdir ~/.vnc
wald@jetson: vncpasswd
Then create a file ~/.vnc/xstartup with the following content:

Start Gnome 3 Desktop

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
vncconfig -iconic &
dbus-launch --exit-with-session gnome-session &
Then once this file exists, start tigervnc
wald@jetson: vncserver

TigerVNC should now be running, but since you already have a gnome display running you’ll get some warnings about display :1 already being used, and it using display :2. That’s OK, but will mean that the port forwarding will look a bit different from what the google’d page suggests, namely, display :2 uses port 5902, not 5901.

Thus, from your remote machine (in my case a linux box named ‘trinity’, but putty should allow the same from windows, too): Create a port-forward of localhost:5902 to jetson:5902
wald@trinity: ssh -vv wald@jetson -L 5902:
Then once that port is forwarded you can connect with any vnc viewer, in my case tigervnc as well:
wald@trinity:~$ xtigervncviewer

And la voila, i get a window with my remote desktop.

Now as I said above, I’m not exactly a windows expert, nor a frequent VNC user, so I won’t even try to give guidance on using tigervnc or port forwarding on windows… Both should work, but that’s as far as I’ll go :-)

Hope that helps!

Hi jcceccaldi,

Are you using Jetson AGX Xavier or DRIVE AGX Xavier?
This forum is form DRIVE AGX platforms.
If you’re using Jetson platforms, please open your issue at

Dear all,

Could you please refer to the following link for DriveAGX remote setting? Thanks.

Another remote access guidance. FYI!