amd ryzen 5 mobile nvidia gtx 1050 login loop ubuntu 18.04

I have changed but nvidia-settings still not working.

Please create a new nvidia-bug-report.log

http://paste.ubuntu.com/p/TkmgnZ2CPP/

Please add

Option "PrimaryGPU" "Yes"

inside the OutputClass of /usr/share/X11/xorg.conf.d/10-nvidia.conf
Afterwards, create a new nvidia-bug-report.log

great, it’s worked and what about how to switch gpu between amd and nvidia ?
nvidia-bug-report.log (2.07 MB)

Try running

sudo prime-select intel

and reboot to switch to amd.

To save your config, run

sudo mkdir /etc/X11/xorg.conf.d
sudo cp /usr/share/X11/xorg.conf.d/10-nvidia.conf /usr/share/X11/xorg.conf.d/10-amdgpu.conf /etc/X11/xorg.conf.d

it’s worked , thank you a lot.

This method works for me also. I am using an ASUS Vivobook X570ZD with R7 2700U and Gtx 1050 on Ubuntu 19.10. I am experiencing a lot of screen tearing though and there are a lot of options missing from the Nvidia X Server Settings Menu like PRIME Select, also the Advanced button in X Server Display Configuration is not working. Any ideas how to fix these issues? I am sort of new to linux so if you need any other info that might help please tell me what I need to provide!

  • Tearing: the amdgpu driver has to implement prime synchronization, I guess that this is currently only implemented in the intel i915 driver, you’ll have to poke the amdgpu devs for that.
  • The ‘Advanced’ button is in general not available on prime displays since it is handled by the igpu. No bug, won’t change.
  • The prime select feature is an ubuntu feature, they’re running a patched version of nvidia-settings. The config changes needed to get the amd/nvidia combo running are because Ubuntu’s nvidia-prime and gpu-manager don’t expect/support this. Please file a bug at Ubuntu’s bug-tracker for the nvidia-prime package to get support for amdgpu/nvidia combos.

Thank you for enlightening my dumb mind :))
I will try to do some more research on the amdgpu prime sync!

I suspect those are the patches for the i915 driver:
https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/log/drivers/gpu/drm/i915?h=v5.3.9&qt=author&q=goins
Don’t look that complicated, asking the amdgpu devs on freedesktop.org nicely should be worth a try.

Dear all,
Somewhat similar problem:
Asus TUF laptop with Ryzen CPU (vega 10 IGPU) + Nvidia RTX 2060.
Ubuntu 18.04 linux, 5.0.0.37.

On 5.0.0.36 kernel my laptop screen and an external samsung screeen worked (internal probably on vega, external on the only HDMI available which is connected to the NVIDIA card with drivers 4.35 - same situation also reported on windows 10 which I have in dual boot).

On dec 7 linux wanted to update the grub and when I restarted only the laptop screen still works, but not the external. I’ve changed now to ubuntu-nvidia drivers 4.40 (from PPA)

xrandr reports only the laptop screen, not the external.
gnome display also sees only the laptop one.
nvidia-smi reports the Nvidia gpu working

any ideeas on how to access the external screen ?

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP-1-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
1920x1080 120.00*+ 48.00
1680x1050 120.00
1280x1024 120.00
1440x900 120.00
1280x800 120.00
1280x720 120.00
1024x768 120.00
800x600 120.00
640x480 120.00
nvidia-bug-report.log.gz (1.1 MB)

Please check if this makes the external monitor work again:
https://devtalk.nvidia.com/default/topic/1066683/linux/ubuntu-18-04-3-blank-screen-at-startup-with-430-drivers-and-gtx-960/post/5402308/#5402308

Oh, The solution from the link you gave(modesetting=0) worked flawlessly(even my tensorflow docker still sees cuda, and the 2 screens work) - I’m really sorry that I spend the last 4 hours installing and reinstalling drivers and rebooting again and again.

Thank you and next time I’ll have problems I’ll be sure to ask in the group sooner.

Best regards,

hi there,

I recently made an ubuntu mate install on an asus laptop and have issues with nvidia drivers. My google searches eventually lead me here, because I have a quite similar graphic configuration as OP.

01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] (rev a1)
04:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] (rev c4)

Basically when i install nvidia drivers (435 or 440) via apt-get i get blackscreen on reboot. I still can work on console though.

I tried many things. I understand that there is a problem whith xorg.conf file and tried random modifications I found on forums. But nothing yields any results. I have to admit I don’t quite understand exactly what does xorg.conf file.

I tried to do what was told to iam.werter, but it didn’t help. I assume the answers to him where very specific. Also I installed lightdm but it didn’t asked me to be default, I then found out that gdm wasn’t installed before.

Thanks for your help
nvidia-bug-report-1.log (8.85 MB)

Hi generix, Thank you for your time and support. I don’t know how to contact amdgpu devs on freedesktop.org. That site is one page only. I can’t find forum or contact form for that purpose.

Regards

Hi, I am really late into this conversation and somewhat of a novice in these matters.
I have a radeon vega mobile gfx and nvidia geforce gtx 1650. I have ubuntu 18.04 and my default gpu is the amd one. So I have been trying to switch to nvidia for a while and following the instructions on this thread but whenever I set
Option “PrimaryGpu” “Yes”
in the /usr/share/X11/xorg.conf.d/10-nvidia.conf file and reboot, either I get stuck in a login loop or the login screen never comes. I have lightdm installed and running and I have already set
Driver “modesetting”
at the /usr/share/X11/xorg.conf.d/10-amdgpu.conf file.
Also Nvidia X server setting is showing an empty window.
Also I did
prime-select nvidia
and update-initramfs -u
.
And when I ran the command

sudo rm /etc/modprobe.d/blacklist-nvidia.conf /lib/modprobe.d/blacklist-nvidia.conf

I figured that those files were not present in the first place.

Can someone please help me fix this issue???
Thanks in advance