Anaconda for Jetson Nano


I just bought an AMAZING Jetson Nano yesterday, and I realized that Jetson Nano runs on a AArch64 architecture. So the official version of anaconda is unavailable.

Until I found this: Archiconda, a distribution of Conda for 64 bit ARM platform.

If anyone needs this, plz review: Releases · Archiconda/build-tools · GitHub

I think that Archiconda should also be able to be installed on Jetson TX1/TX2 but I didn’t tried.



Thanks for sharing it. I just install it.

I see a bash shell at Archiconda With just conda-forge

I have HDF5 tools installed.
Do you know of any requirements beyond that?
Could you please provide a procedure to install it?
Thank you.

To answer my own question, I went to this link:

Clicked on:
It downloaded to /Download folder
In terminal:
gerardg@Nvidia:~$ cd Downloads
gerardg@Nvidia:~/Downloads$ bash

Do you know how to launch archiconda3?

1 Like

Ihave the same question

@phd.matamoros: Have a look at which shows how to install and use Archiconda on a Jetson (Nano) - in this case inside Docker.

See for the overall project where this is used as part of the “ml-base” Docker Image including Jupyter notebooks in the “jupyter” image - see

The build instructions in the Dockerfiles can be easily replicated on the host in case you don’t want to use Docker.

@friskit.china: Thank you for sharing this info! I was not aware of archiconda’s existence and was racking my brain how to get anaconda installed on aarch64 - then i saw this post.

For me getting the archiconda3 work came down to adding the path to the directory of its installation to the environment variable PATH.

Unfortunately, this only works for systems that return uname -m as aarch64. Fails if it comes back arm71, like my Raspberry Pi on Raspbian.

I installed archiconda successfully on my Jetson TX1. However, when I try to run conda update I get an error:

nvidia@nvidia-desktop:~/archiconda3$ uname -m
nvidia@nvidia-desktop:~/archiconda3$ conda update -n base --all
Solving environment: failed

NotWritableError: The current user does not have write permissions to a required path.
path: /home/nvidia/archiconda3/pkgs/urls.txt
uid: 1000
gid: 1000

If you feel that permissions on this path are set incorrectly, you can manually
change them by executing

$ sudo chown 1000:1000 /home/nvidia/archiconda3/pkgs/urls.txt

In general, it’s not advisable to use ‘sudo conda’.

I tried looking for the “urls.txt” file under the above path but it doesn’t seem to exist. Any ideas?


This is a permission issue.
Have you try to execute the command with root to see if works?

<b>sudo</b> conda update -n base --all

Or update the permission of this folder:



1 Like

Dear Sir:

The big problem is that archiconda3 lacks of the installation environment of tensorflow-gpu. So it failed to install tensorflow-gpu. Do
you have any solutuion to the problem.

PachagesNotFoundError: The following packages are not available from the current channels

  • tensorflow-gpu

I am pleased to add the installation steps as follows.

Installation Steps

  1. create an environment:

conda create --name tf_gpu

  1. activate tf-gpu

$ activate tf-gpu

  1. install tensorflow-gpu

$ conda install tensorflow-gpu==2.0.0
$ conda install tensorflow-gpu

  1. Failed messages

PachagesNotFoundError: The following packages are not available from the current channels

  • tensorflow-gpu

Thanks in advance,

For those who are already familiar with installation and setup for anaconda or miniconda the steps for archiconda are similar. First download and install a version of the archiconda installer:

# use install path: $HOME/archiconda3
wget --quiet -O && \
    sh -b -p $HOME/archiconda3 && \

Next we update the conda environment and add channels containing recipes for 64 bit Arm packages.

export PATH=$HOME/archiconda3/bin:$PATH
conda config --add channels gaiar && \
conda config --add channels conda-forge && \
conda config --add channels c4aarch64 && \
conda update -n base --all && \
conda install -y python=3.6.7 libiconv && \
conda install -y conda-build && \
conda install -y anaconda-client

A standard conda environment should now be available in $HOME/archiconda3/bin. To automatically edit your .bashrc and activate the base environment on login, use conda init bash or see $HOME/archiconda3/etc/profile.d/

I hope it helps,