Android: HDMI default resolution on Jetson TK1

Hi, all

I flash the jedroid into Jetson TK1, and connect HDMI to 4K TV, the default resolution is 1080p,
I changed the framebuffer to 4k (3840x2160p30) for kernel, but it no effect.
It always display 1920x1080p60 mode, so I deleted all the 1080p60 related clock 148.5Mhz,
But it still display 1080p60, can someone tell me any idea?


I’m not sure if the video hardware is actually capable of 3840x2160. Someone with more video knowledge might be able to shed a light on what is required for that resolution…especially if attempts to run at this resolution failed or succeeded.

Android has its own ways of selecting the resolution and I don’t know anything about how Jedroid does it.

On Ubuntu side 3840x2160p30 works normally by selecting it with xrandr. There are probably many tools for that, I used lxrandr.

At least with the TV I tried, UHD is not listed as the “recommended” mode (afaik) but 1080p60 is, that’s why UHD has to be selected manually.

Thanks for your reply.

On Ubuntu, it’s run normally well on my Jetson TK1, and I used xrandr command change UHD resolution.
But I want to see the 4K video quality for android.

I tried to select resolution manually by two ways.

  1. adb shell wm size 3840x2160
    Although the android layer is 3840x2160, but the real signal source was 1920x1080.
  2. echo ‘size’ to /sys/class/graphics/fb0/mode
    First I checked the supported size
    cat /sys/class/graphics/fb0/modes


then setting size by adb with root
echo 0 > /sys/class/graphics/fb0/device/enable
echo D:3840x2160p-24 > /sys/class/graphics/fb0/mode
echo 1 > /sys/class/graphics/fb0/device/enable

checked size by cat /sys/class/graphics/fb0/mode
the source signal become 3840x2160, but the screen was smaller than quarter of the original!

Android doesn’t support changing resolution on the fly. But even if you first configure mode with the sysfs and only then start the Android frameworks it may be hardcoded to 1080p.

L4T for Jetson TK1 does support 4K display. Not clear if 4K is verified in jedroid since it’s not officially supported.