Android Lollipop on Jetson TK1

Hi Everyone,
Recently I tried to port Android Kitkat over Jetson TK 1 Board taking reference from https://devtalk.nvidia.com/default/topic/767885/embedded-systems/android-on-jetson-tk1/1/.
Really the above link was very useful and I learnt a lot about Android Porting. Out of Interest, I have decided to port Android Lollipop over TK1, but couldnt find any reference. Have anyone started Lollipop Porting for Jetson TK1?

Isn’t the post #205 on that thread exactly about what you are asking for?

https://devtalk.nvidia.com/default/topic/767885/embedded-systems/android-on-jetson-tk1/post/4524940/#4524940

Yeah, I tried it but I wasnt successful and am facing some issues with libEGL and surfaceflinger seems to crashing, with the following messages.

W/libEGL ( 118): eglInitialize(0x1) failed (EGL_BAD_ALLOC)
W/SurfaceFlinger( 118): no suitable EGLConfig found, trying a simpler query
F/SurfaceFlinger( 118): no suitable EGLConfig found, giving up

Hence I decided to seek some help regarding this issue in this post.

I don’t know much about this, other than Google has a port for the Jetson TK1 that they use for Project Ara. Here are the Build and Boot instructions for the Jetson:

https://github.com/projectara/Android-wiki/wiki/Build-and-Boot-Instructions-for-Jetson-reference-platform

Might be an interesting read through.

Hi Everyone,
I just somehow solved the libEGL errors. But I cant understand these things,

D/NvOsDebugPrintf( 131): Opening channel /dev/nvhost-vic (0x6a) failed
E/( 131): Sync: ERROR close(<0:UNKNOWN>) returned -1 [NvDdkVicFreeSession]
E/viccomposer( 131): nvviccomposer_create: Failed to create vic session: 30012
W/SurfaceFlinger( 131): no suitable EGLConfig found, trying a simpler query
F/SurfaceFlinger( 131): no suitable EGLConfig found, giving up

Are these stuffs related with my kernel configuration or am I missing something else?

Hi John,

We have a working android lollipop port available for the Jetson TK1. And a free evaluation binary is available for download. Please have a look at the following link to know more about its features.

http://www.e-consystems.com/jetson-tk1-android.asp?aljfrm

Feel free to try it out and let us know your comments.