Ansel responding to mouse & keyboard even when not in focus

This is a regression from Studio driver version 462.59 to 471.11 (and continuing to current 472.12).

In 462.59, when an Ansel session was started (the UI came up), it would hide the windows cursor and show its own cursor captive to the game window. If you Alt+Tabbed out or used the Windows key to wrestle focus away from the game window, Ansel would hide its own cursor and ignore keybaord and mouse input.

In 471.11 and after, when an Ansel session is started, it still hides the windows cursor and shows its own cursor captive to the game window (same as before). However, now when removing focus from the game window, the Ansel cursor stays active and responds to all mouse and keyboard input, as well as the actual windows mouse. This leads to clicks on other monitors or keyboard strokes in other focused windows actually being responded to by the Ansel UI as well.

This causes issues for us as we use Ansel to render images in the background while continuing to use the workstation to perform other tasks.

This occurs in both UE4.26 and UE4.27 and is repoducible only in the driver versions stated above. Additionally, this is using the original Ansel implementation (in the Program Files\NVIDIA Corporation\Ansel\ folder), since the new Ansel implementation does not allow rendering in non-fullscreen mode, and is unable to perform a background render when the game is not in focus.

Hi @cameron.abt , welcome back to the forums!

Thank you for bringing this to our attention. Sadly I don’t have an immediate fix for you, but I will bring this up with our developers. If they require more information, I will post here again or send you a direct message.

In the meantime, you might want to check out the related community in our dedicated GeForce end-user forums, it is possible someone had the same issue and found a workaround.

Cheers,
Markus

Thanks Markus. I checked through that forum before posting and couldn’t find anything similar. I also tried to post there first, but for some reason the Create button wouldn’t enable after I was putting in the title… EDIT: Ok, turns out the UI isn’t great and the “Title your topic” section is a text input field while I was trying to put the topic title in the body section. I’ll cross post there too.

Happy to hear from development though, I expect chances of a solution are higher here.

Cameron

You are welcome.

One quick follow-up if you don’t mind, which version of GeForce Experience are you using?

Thanks,
Markus

I re-installed Studio driver 462.59 including the GeForce Experience version that came with it, so I’m currently running 3.23.0.74 which is functional. (EDIT: it actually looks like 3.23.0.74 is the most recent version, not the version that would be installed alongside 462.59. I expect when I downgraded from 472.12 back to 462.59, it kept the newer version of GFE and didn’t install the older 3.22.0.32 version)

When upgrading to the new (non-functional) drivers, I did a clean install and included the GeForce Experience install with those drivers - I don’t have those GFE versions offhand.

Just to make my original post more clear, the Ansel version we’re using has a UI that looks like the attached image.

Thanks again,
Cameron

Thanks for the additional picture, I will add that to the issue report.

The GFE version did not change as far as I am aware, so that information also helps.

Markus

Perfect, thanks. I figured I might as well add a video to show the issue too. This is taken after a clean install of Studio driver version 472.12, installed from the non-DCH version (472.12-desktop-win10-win11-64bit-international-nsd-whql.exe):

Hey Markus,

Have you heard anything from the developers? I saw a new studio driver was released (472.39) and was hoping maybe that fixed the issue.

Thanks,
Cameron

Hi Cameron,

I am sorry, I don’t have an update for you yet. But I am following the progress internally and will post here if there are news.

Thanks for your patience!
Markus

Has this issue been resolved? I’m having the same thing happening to me as we speak.

No, unfortunately it’s not fixed. We’ve been using an outdated driver this whole time and I’d love it if there was something else we could try.

Hi guys and welcome @cjkyles to the NVIDIA developer forums.

Unfortunately I cannot share any good news with you. Since the focus of Ansel support has shifted to GeForce Experience and the In-Game Overlay usage of it, the standalone version of Ansel, the one showing this behavior, had to be deprecated.

But on the good side, now that UE5 is out, the Ansel plugin for this version needs to be refreshed, so you should send your feature requests through the GFE Feedback button to the team.

If I understood it correctly this is mainly about two things:

  • use Ansel in non-fullscreen mode
  • and let Ansel do the render in the background (although I wonder why, it should not take that long in the first place?)

I can possibly relay that as well.

Sorry again that I can’t give you a better solution, but I hope this information is still useful.

1 Like

@MarkusHoHo thank you for the help!

Let me share a few notes about our workflow to give you an idea about our use case. We work in archviz and place many (~100) cameras in each project we work on. We use internally developed tools to do lower quality 4K 360 renderings, but rely on Ansel’s high-res tiling capabilities to produce final, 16K 360 and flat renderings, with ray-tracing turned up to 11. Because of this, it can take 15 minutes or so on our hardware to render out a single image.

We’ve created a keyboard macro to tab and arrow into the proper mode and settings, start the render, wait for the cancel button to go away, then get out of the Ansel interface. It moves to the next camera automatically, then starts the next one up. We force the game to run in windowed mode at 1280x720 to ensure the macro works properly, the graphics driver doesn’t timeout, and the computer is more generally usable (when not using the macro, as detailed below).

When using the macro the issue above isn’t a huge deal since there’s no other interaction. Sometimes we do have to render some images using Ansel manually though, and that’s where it becomes an issue when we let it render in the background and try to work on other tasks in the foreground (since all the clicks and mouse movement are duplicated in the Ansel window.

If there is opportunity to get some requirements in front of the GFE Ansel team to work better with our workflow, that would be outstanding. In particular, we’d love to deprecate our use of a macro as it’s a very fragile implementation dependent on the UI layout and even button sizes.

  1. Ability to control render mode (360, 360 stereo, superres, etc) through blueprint and/or C++ api
  2. Ability to control resolution and other settings through blueprint and/or C++ api
  3. Ability to start a render through blueprint and/or C++ api
  4. Ability to force the rendered images to use a particular name when starting a render
  5. Callback when render has completed (or ability to poll whether or not it’s still running) through blueprint and/or C++ api

It sounds like there’s a different version of Ansel built into GFE now. Does that work the same way as the standalone Ansel version (in terms of plugin integration with UE4)? We use a config file to maintain consistent settings across the standalone version (applied to the registry), where are settings saved for the new version? Perhaps using this version can be the new plan.

I’ll use the “Send Feedback” button in GFE to put this in front of that team as well.

Thanks again,
Cameron

Hello, I think we are friends on the same road. We are also using Ansel to deploy the automatic rendering process, and we also encounter the failure to effectively set the expected mode and automatically start rendering. Can you share your scheme and code

Hello and welcome to the NVIDIA developer forums @1317489420 .

I just realized I never thanked you for your input @cameron.abt ! I am so sorry!

I forwarded the info as well, but overlooked to reply here.

Otherwise no further information from our side I am afraid. And regarding your question:

Does that work the same way as the standalone Ansel version (in terms of plugin integration with UE4)?

It does not, no. There is no readily available plugin connection to UE from GFE.

Thanks @MarkusHoHo for keeping us in the loop.

Is there any type of API access to Ansel in GFE at all, outside of UE4? If that’s the case I could whip up some middleware to talk between the two for now. My fear is that Ansel is only meant to used by a gamer and a mouse.

Cameron