Any OCR model run in Jetson Nano

Hello all,

Is there any inference available for OCR model?

Just a suggestion, it will be really good if the title could list similar questions as our question. so if a similar question has been asked before we will not post a repetitive question(Like the StackOverflow).



Sorry that we don’t have an official OCR model.

One of our partner who focus on the ALPR may have a similar experience:
You can check their doc for more information:


1 Like

On this subject are there any other OS distributions for the nano than Ubuntu 18.04 LTS? OpenALPR’s installation instructions for the easy way

installs fine, but for some reason whenever I run certain images I always get “Segmentation fault (core dumped)” errors that I never get running the same images on the appropriate version of Ubuntu on Raspberry Pi.

you need to compile it so it uses the GPU. the easy method installs only for CPU.

Can you explain command by command how to compile OpenALPR to run on the nano then? I have tried to multiple times to do so and run into problems with Leptonica no matter how I do it. This seems like one of the most common uses for this device so I am surprised that by now I haven’t seen any step by step guides demonstrating this.

You might want to try building Tesseract:
It can optionally use a GPU for some part of the work, (using OpenCL, not CUDA) but it’s not a full “learning” model.
Edit: Turns out, Tesseract version 4 now has a trained NN model, too!

You can install these pre-built (including the library / headers) on the Nano by doing:

sudo apt install tesseract-ocr libtesseract-dev

brentisgrimm, You can read more about Raspberry Pi on

1 Like

Hello, I’m getting the same error as brentisgrimm. If the solution is to compile so that it uses the GPU (as opposed to the CPU which I guess it defaults to?), can you explain how to do that? I looked at the solution proposed by oyenekanseyitan but I’d rather not have to pay a subscription fee … Any help?

What’s wrong with Tesseract? Works fine for me!

Hi, thanks for jumping in so quickly.

I’ve installed Tesseract as well as Liptonica but still get the same error. Do I need to do anything differently than apt install them?

So fair I’ve followed these commands:

sudo apt install openalpr openalpr-daemon openalpr-utils libopenalpr-dev

Then moved the “tessdata” up a directory after the first error, but still get the “Segmentation fault (core dumped)” error when running certain images or videos.

Is it possible not all of the dependencies are in the libraries and following your suggestion for Tesseract would solve that?


Hi snarky, I am new.

I will soon have a Jetson Nano Dev Kit and will employ it for different uses.

The first topic I have searched for is based on Tesseract. My PC just is’t adequate. The newer Tesseract LSTM 4.0 model seems like it may be a good fit on the Jetson, though.

I have developed my own font from a facsimile. I now want to better train the newer OCR engine to textually render the trained font from many similar facsimiles. It is actually Greek.

Can you offer any helpful advice or references for running the LSTM model successfully?

I will greatly appreciate and gladly reciprocate anything I learn on the topic of Tesseract OCR with the Jetson platform.

I have successfully installed tesseract and vs code but vs code gives error stating no module name pytesseract plz help