Any OpenGL window shown on all workspaces, occludes other applications

When no compositing window manager is used in Xorg, any OpenGL window will permanently be drawn on top of all other windows and on every workspace. The issue seems to have been around for at least for months, cf. the following forum threads.

https://bbs.archlinux.org/viewtopic.php?id=177462
https://bbs.archlinux.org/viewtopic.php?id=177476
https://bbs.archlinux.org/viewtopic.php?pid=1370960
https://bbs.archlinux.org/viewtopic.php?pid=1371241

Is NVIDIA aware of this bug? I’ve tried locating related threads in here but have not been succesful.

Can’t say I can repro it with i3wm or mcwm.

One additional observation is that once I try running a GLX compositor as a workaround, I get the redraw issues that are reported elsewhere here, with parts of stale buffers showing up in application windows, e.g. when scrolling.

Btw. this is on Linux 3.14.5, Xorg 1.15.1 and driver 337.25. I’ve submitted a full debug log by mail. The number of forum posts elsewhere on the net suggests that this is a common issue when not running a compositing WM on this configuration.

I cannot reproduce it with KWin (3.5.10).

After cursory examination of the various related threads, this behavior seems to manifest mostly in conjunction with Xmonad, openbox and awesome WM, and only when no compositor is enabled. I myself see this bug when using qtile.

I have temporarily installed the Nouveau drivers and could observe that this made the issue go away completely; due to lack of fan and voltage control, I’d prefer a solution based on the official drivers, though.

I have the same problem and can reproduce it on any non-compositing window manager (marco, openbox, KWin - all with compositing disabled). I find google chrome 35 one of best things to demonstrate the problem - run chrome with compositing disabled, perform right-click somewhere near border so context menu will exceed chrome’s window size, then left-click within its window. Area where context menu was becomes white, regardless of what it was before. It isn’t happening with compositing enabled, on any WM.
Sometimes it shows chrome window on another desktop, but I can’t figure out 100% repeatable example. Of course disabling hardware acceleration in application removes this problem, but it is hardly a solution. With full-screen games, it almost impossible to switch to another desktop because it almost always overdrawn by fullscreen GL from game.

Nvidia driver 337.25, kernel 3.14.5. See this problem for quite a time (at least half a year, maybe more), so it surely isn’t limited to latest driver release.

If it isn’t clear (sorry then), here is how it looks like: http://youtu.be/1-WBT1_uN9Q

I have the same problem as well. I’m using xmonad on Arch Linux. I also have an i3wm lock screen but the problem does not occur with that.

In the following example (http://files.awhetter.co.uk/GLWorkspaceBug.png) I have chromium running on the first workspace. On the second workspace Spotify is running above a terminal. I switched workspaces and the Chromium window displayed over the workspace. I then ran the bug reporter and took the screenshot. Here is the log file: http://files.awhetter.co.uk/nvidia-bug-report-GLWorkspaceBug.log.gz

I’m using driver version 337.25, kernel 3.14.6, and xmonad 0.11. The problem also occurs when I have another monitor plugged in.

EDIT: I also forgot to mention that if I switch from a workspace with an OpenGL window to an empty workspace, then back to a workspace without any OpenGL windows then I don’t see the problem again until I switch back to a workspace with an OpenGL window.

I can confirm this on 337.25, kernel 3.14.5 and KWin from 4.13.x (Arch).
Chrome frame keeps being drawn randomly on top of screen when both Chrome windows are minimised (I have two windows opened all the time). After I maximize them again they would randomly flicker between each other. Unmaximizing and not minimizing them helps preventing further glitches. I observe this with both composited (OpenGL 3.1, raster, no thumbnails) and non-composited modes.

Thanks for reporting this. I reproduced the problem and filed bug 1525147 for tracking. However, it does look like this is a regression in the X server between version 1.14 and 1.15 so it might not be an NVIDIA driver bug.

I see a similar behavior/interaction with the Steam client: put firefox on the desktop,
start the steam client, minimize it, and watch the glitches.

I can no longer see this problem after updating to 340.24. Could others confirm it is fixed?

I also haven’t seen the problem since upgrading to 340.24!