Any solution except reflash for losing the display in Drive AGX?

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
native Ubuntu 18.04


I saw the issue of losing the display after power cut or sudo reboot on different drive AGX we have and We need to reflash the drive AGX and install the display and other SWs again.
Is there any other solution except reflashing and what is the root cause?

Thank you,

Dear @user158496,
Do you notice this issue on all DRIVE AGX platforms you have? what is the status of display manager after reboot? Please check if reinstalling gdm3 fixes the issue?

Dear SivaRama,

Yes I do have the same issue on all the drive AGX we have. There is no display after reboot. Reinstalling the gdm3 is not fixing the issue, only reflashing.

Thank you.

Dear @user158496,
This is strange, Could you try with lightdm instead of gdm3 in . It worked for customers like here

Same problem here: E3550, DriveOS 5.2.6.

After flashing everything works fine. Enabling GUI (unity via gdm3 or lightdm) also works fine. - But as soon as package-update via Ubuntu Updater is finished and rebooted: no HDMI output anymore. Screen keeps black. PUTTY console saying ~“FBMON rate below min”.

I’m having the same problem. Same configuration. Upon reflash, I’ve tried using lightdm as the display manager instead of the recommended gdm3 as well. Lightdm will work, but it fails eventually in the same fashion as gdm3.

The HDMI output no longer works after a few sudo reboots. It will occasionally continue working after sudo reboot.

Hey, I want to mention that I’ve been having similar issues. I’ve been forced to power cycle the AGX instead, but even then, eventually the display will no longer work.

This issue seems to affect Xavier B more so than A in my own experience, and I’ve had to re-flash the drive AGX multiple times as a result.

Dear @jason.wu2,
I don’t notice this issue yet. I will try few experiments and update you.


Any news?

Hi @michael.honey ,
Did you reboot the target couple of times immediately after enabling display and hit this issue?

HI SivaRamaKrishnaNV,

Reviving this thread. I just did a clean install on the AGX and still ran into the issue with a missing display on Xavier B. I rebooted the second Xavier multiple times but it hasn’t fixed the issue. ssh works fine for both, it seems just the GUI doesn’t not behave consistently.

Were you able to replicate the issue?

Dear @william.guo,
I rebooted the machine couple of times and did not hit this issue.

Dear @william.guo ,
Do you notice same symptom of config files removed when you hit the issue as in Display manager gets destroyed after reboot - #4 by anil-kumar.chavali

I will check the system and let you know. Thanks for bringing this to my attention.

1 Like

If I understand correctly, anil-kumar’s solution is not installing any updates after setting up GUI (with gdb3).
I’m following the same approach, but would not call that a ‘solution’.
We would come closer, if we could identify which package causes the system not to work anymore.