Anybody know a way to use GTX 960m on ubuntu 16.04?

I am using ubuntu 16.04 on the i5 version of dell inspiron 15 7559. The system cannot shutdown.

I cannot login after installing the nvidia driver from additional driver. None of the nvidia drivers in the graphics ppa worked.

Does anybody knows how to make this work please?

Thanks.

A) Never buy or update anything without first conducting an extensive search.

B) Never buy a notebook which does not have a DVD burner. Though it will be seldom used, an internal DVD drive offers a handy option for installing an OS.

C) If one is intent upon buying an Intel-based notebook for use with Ubuntu then a purpose-built System76 lappy is one time saving option worth checking out:

Laptops - System76
https://system76.com/laptops

Other options:

ZaReason Linux Laptops, Desktops, Servers and more
https://zareason.com/shop/Laptops/

Top 5 Ubuntu pre-installed Laptop companies | Unixmen
https://www.unixmen.com/top-5-ubuntu-pre-installed-laptop-companies/

D) Contact Dell re getting an .iso of the custom OS that came with the Ubuntu version of your notebook.

[i]"Please note that for pre-installed systems:

The system is available in some regions with a special image of Ubuntu pre-installed by the manufacturer. It takes advantage of the hardware features for this system and may include additional software. You should check when buying the system whether this is an option.

Standard images of Ubuntu may not work at all on the system or may not work well, though Canonical and computer manufacturers will try to certify the system with future standard releases of Ubuntu.

Ubuntu 14.04 LTS 64-bit
Pre-installed by manufacturer"[/i]

Ubuntu on Dell Inspiron 7559 | Ubuntu
https://certification.ubuntu.com/certification/hardware/201508-19027/

E) Try booting with the Ubuntu 16.10 Live DVD in the hope that it offers better support for your notebook.

Ubuntu 16.10 (Yakkety Yak)
http://releases.ubuntu.com/16.10/

F) Study your notebook’s manual re turning off any superfluous rubbish like ‘Secure Boot’ etc. (Search: Secure Boot hacked)

G) Read though the following posts for clues:

[i]"Let me share my experience with Dell Inspiron 7559 + Windows 10.

First I had Windows 10 GPT (UEFI) preinstalled. Had the same splash screen freezing problem. Overcame it by specifying acpi=off kernel parameter (same as you did with nomodeset, but that didn’t work for me, whereas acpi=off worked). I think I would be able to install Ubuntu then.

But I suddenly got a silly issue with the screen - I’ve probably held F11 somewhere and that turned the screen off, so I could not see neither BIOS nor Dell logo. So I put my laptop to the tech service and they’ve worked it out, but also reinstalled my Windows 10. This time that was MBR (legacy, non-UEFI).

And with the Windows MBR, Ubuntu installed like a charm.

Upon Ubuntu installation, I had the following setting in my BIOS:

  • Boot List Option: UEFI (I left it unchanged, not sure if this setting even took effect)
  • Secure Boot: disabled (I disabled it myself because many people reported issues on it)
  • Load Legacy Option Rom: disabled (left untouched)

Also, my BIOS was of the latest version (I followed dell.com website instructions to update BIOS).

After Ubuntu installation, the only issue I had is not being able to shut down properly. Resolved this by going to System Settings > Software & Updates > Additional Drivers and selecting this proprietary NVIDIA driver instead of an opensource one: “NVIDIA binary driver - version 361.42 from nvidia-361 (proprietary, tested)”

Now it works well. I am able to dual-boot Windows because I have it in MBR. I know this is probably not your case, but you may try acpi=off solution or migrating your Windows to MBR (if you know how to do it - 'cause I am not an expert there :)."[/i]

dual boot - Dell Inspiron 7559 doesn’t work with ubuntu linux - Ask Ubuntu
http://askubuntu.com/questions/746015/dell-inspiron-7559-doesnt-work-with-ubuntu-linux

7 Dec 2015
Kubuntu 15.10 on Inspiron 15 7559 Skylake UHD - OS and Applications - Forum - OS and Applications - Dell Community
http://en.community.dell.com/techcenter/os-applications/f/4457/t/19663800

Bottom line:

Based upon all of the above you may be further ahead installing Windows 10 AU 1607 on that notebook and selling it to help finance the researched purchase of a notebook which does work with the OS you wish to run.

I don’t know but I can give you some hints. Quick googling told me that’s a shoddy device.

  1. Update your BIOS if there’s an update available
  2. Get a newer kernel
    2a. Wait a week when 16.04.2 is out, it comes with a 4.8 kernel -or-
    2b. Install it from a ppa: https://launchpad.net/ubuntu/+source/linux-hwe-edge
  3. Always, always-always-always run nvidia-bug-report.sh and attach the output to your post by editing it
  4. Since it is a notebook, is it Optimus enabled, i.e. all outputs just connected to intel graphics?
  5. ‘Can’t login’ is not a proper error description. ‘Can’t shut down’ neither.

First of all…yes, Dell Inspiron 15 7559 isn’t the best option for linux…unless you buy it with the system installed from Dell.

I have one with DUAL BOOT in UEFI, on a M2 SSD, so I’m proof that it is possible!

There are three main problems with this computer for use it with Linux, the WIFI card, the two graphic cards and the subwoofer… I’ll try to explain how I did to fix them.

### WIFI Card ######
The wireless drivers need at least kernel 4.5.0, all you need to do is connect the note to a cable network and upgrade the system.

  sudo apt-get install linux-firmware 
     or 
  sudo apt-get upgrade

### NVIDIA Graphic Card ######
Install the latest drivers to solve the memory lockup problem on shutdown/restart.

  sudo add-apt-repository ppa:graphics-drivers/ppa
  sudo apt-get update
  sudo apt‐get install nvidia‐364 nvidia‐prime
  sudo apt-get install nvidia-modprobe

Change the nvidia-364 to the latest you can find on the list.

### The Sobwoofer ######
To solve the subwoofer we need to remap the ports using HDAJackRetask:

  sudo apt-get install alsa-tools alsa-tools-gui

launch HDAJackRetask and:
- Check “show unconnected pins”
- Remap 0×1b (“Not connected”, which is the subwoofer) to “Internal speaker (LFE)”
- Install Boot Override
- Restart

Now, just open your “Sound Settings” and change the Output Profile to Analog Surround 4.0. Ajust the balance of the subwoofer with the Fade property.

I hope those information could be useful.