Anyone able to ping nvidia.com?

Hi.

Anyone able to ping nvidia.com ?

I tried to ping nvidia.com from several PCs , and tried in a few online ping website, all failed.
the IP is 34.194.97.138

ping 34.194.97.138 <— failed
nc -vz 34.194.97.138 80 <— OK
nc -vz 34.194.97.138 443 ← OK

And sdkm rely on “ping nvidia.com” to pass the internet check.

Hi,
We are able to ping the website:

nvidia@tegra-ubuntu:~$ ping www.nvidia.com
PING e33907.a.akamaiedge.net (23.193.119.198) 56(84) bytes of data.
64 bytes from a23-193-119-198.deploy.static.akamaitechnologies.com (23.193.119.1
98): icmp_seq=1 ttl=45 time=35.7 ms
64 bytes from a23-193-119-198.deploy.static.akamaitechnologies.com (23.193.119.1
98): icmp_seq=2 ttl=45 time=35.7 ms
64 bytes from a23-193-119-198.deploy.static.akamaitechnologies.com (23.193.119.1
98): icmp_seq=3 ttl=45 time=35.5 ms
64 bytes from a23-193-119-198.deploy.static.akamaitechnologies.com (23.193.119.1
98): icmp_seq=4 ttl=45 time=35.5 ms
64 bytes from a23-193-119-198.deploy.static.akamaitechnologies.com (23.193.119.1
98): icmp_seq=5 ttl=45 time=36.1 ms
^C
--- e33907.a.akamaiedge.net ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4004ms
rtt min/avg/max/mdev = 35.537/35.695/36.065/0.192 ms

Maybe you can try other network.

Hi.

Yes, I’m able to ping www.nvidia.com also.
But not nvidia.com (without www).

sdkm uses both 2 commands to check internet connection, one without www and one with www:
ping -c 3 nvidia.com
wget --spider -T 5 -t 1 www.nvidia.com

I also cannot ping “nvidia.com”, either directly, or via ping of 34.194.97.138. Sometimes though this is because ICMP echo is turned off and not due to route. For route, what happens if you go to a browser and enter http://nvidia.com? For me this works. I’m thinking the ping -c 3 nvidia.com will indeed fail, but the wget will succeed. I think there might be a flaw in that if ping is required…maybe edit to bypass the ping for now.

One other thought…maybe NVIDIA could switch to detecting text in this to know if an address is available (adjusted for case):
curl -l nvidia.com 2>/dev/null

This retrieves the header. If the web site does not resolve, then there is no output. If the web site does resolve, then there is a small amount of text in the form of the header of the web page. One could also redirect “2>fail.txt” and print the failure message if there is an error. What this does not do is depend on ICMP protocol; what it does do is look for non-error reply by the web server.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.