Anyone have issues with ethernet port?


I just received TK1 board and I am not able to connect to the internet at all. I am wondering if my board is defected or if I’m doing something wrong. So I wanted to check if others has seen this.

I powered up the board for the first time to command prompt and logged in to run script. I rebooted to a gui session afterwards but my ethernet shows disconnected.

I tried

sudo dhclient -v eth0

And I got “failed to send packet over eth0 interface”

I also tried

nmcli dev

eth0 802-3-ethernet unavailable

Any ideas?


I use static IP on mine and just edited files with no issue. By default though L4T uses DHCP. I’m going to make a guess that if something wasn’t causing an issue, the dhclient command wouldn’t be needed. FYI, if it had worked directly to the Internet, without a router to block logins originating from the outside, someone could have quickly detected the default ubuntu login and done something…not likely the case but something to keep in mind.

What does “ifconfig” show?

Also, are you using a router or do you have a private net or going straight to the Internet?