Anyone have soft cloth hair working?

Reallusion is taking forever to support this and I can’t see why we need to wait - there must be a manual solution, but I have not been able to get it to work quite right.

Whatever I do, the hair ends up at the feet of the character. It appears to be staying aligned correctly with the head, it’s just in the wrong position.

I’ve tried adding a scalp object and giving that rigid collider physics and attaching the hair, but I have not gotten that to change anything. So close and yet the hair so fair away. Literally.

Has anyone worked out how to get the hair in the correct position?

Hello @markrmiller! I forwarded this over to an expert to help! What is your current workflow? Are you experiencing this issue in Character Creator or are you importing it into another app?

It wasn’t hair, but I tried doing the same with with a character from iClone8/CC4 with a cape and had the result was the same as yours, it was just dropped right down to their feet as soon as I started playing the scene.

My process is to create characters using CC4, animate the scene in iClone 8 before exporting using the Omniverse plugin.

When using iClone’s soft cloth physics, I always leave about 5 seconds before animating a character, to give the soft elements a chance to settle from their default position. I did the same thing with my test project but immediately the cape jumped down to the character’s feet.

Hi @markrmiller,
by saying ‘manual solution’ , do you mean setup the PhysX property manually in Omniverse Create or Machinima?

Hi @darth.angelus
the character exported currently doesn’t have collision shape, so a cape dropped on the ground

Right, I’m trying to get cloth physics on hair using just Omniverse.

I’m dying to make Omniverse my main rendering solution, but unfortunately, everything I’m currently working on involves a character with long hair and if it’s just static, that really prevents me from being able to render with Omniverse. It’s mostly action scenes.

So I’ve been waiting, first for physics in Omniverse and now still for automatic support from the iClone connector. In the meantime, I’ve worked out things in Blender, but I recently thought, hmm, I could do this in Blender without iClone support, of course I should be able to in Omniverse.

A while back, a lot of my physics experiments with soft cloth would crash, but I figured, let’s give it a try with the recent Create release. Crashed once or twice, but worked often enough for me to stick with it.

The hair seems to be be able to do what I want, but of course it drops to the characters feet. Oddly, it still appears correctly oriented and moves with the head, just down at the feet. The drop at least though, was expected.

In Blender, I’d do something like pin the hair to a vertex group on the head. So I went to the Omniverse documentation to find a similar solution. There it looked like the answer was pretty straightforward. To attach the hair, make another object a ridged collider, overlap it a bit with the soft cloth hair, select both and create an attachment.

So I tried that, using a scalp object on the head as the ridged object. Unfortunately, I saw nothing different in behavior. Perhaps I just didn’t have them overlapping correctly? I would have kept trying, but I wasn’t sure I was quite on the right track, mainly because of how the hair still acted like it was soft cloth and connected to the head, but just down at the feet. It is what I want, just in the wrong location, but my expectation was that it would just drop to the ground like a blanket and sit there. And so I was wondering if I was missing something that maybe someone else had already figured out.

Now that you mention it, I didn’t fully think through my lack of collision shapes, I hadn’t seen them mentioned in the doc in the classic “simpler shaped objects approximating the mesh”, but I figured I’d just try making more body parts ridged physics objects or something.

I took another whack at this and I didn’t have any more luck, but I had a bit different experience and realized I was confusing some things.

So I tried I different scene and first I just tried making the hair soft cloth. The girl is on a motorcycle that’s like 10 feet in the air. The hair fell down like cloth, fell as far as it could go. Okay, good.

Now I had some trouble that makes experimenting hard. Previously, I’d use the physics debug panel and hit stop to reset the hair. This time that would not work. I had to reload each time from a fresh copy.

Next I added a collider (which I realize now must be my collision shapes?) and rigid physics to the scalp. I turn off gravity for the scalp and tried both kinematic and non kinematic.

Then I create a physics attachment between the hair and the scalp and bump up the attachment offset.

This is where things get frustrating. Now the hair is doing what I want. It’s flowing, it’s got the right alignment. But it’s down at the characters foot. Not at the bottom of the scene, not on the ground plane. The character is on a motorcycle that is 10-15 feet in the air (static). And the hair is also in the air but down at the characters feet, doing exactly what I want - in the wrong place.

Hi @markrmiller
I am not expert on PhysX neither,
Adam and Michelle are definitely exports on PhysX, but I am not sure whom from NVIDIA would have time to take a look
I think you could send the .usd file to @WendyGram first?
let the NVIDIA expert to comment on the right way to add PhysX manually?
and if PhysX hair can work with USD SkelAnimation?

Thanks for the suggestion! At this point I’m likely back to waiting for reallusion support and doing some renders in Blender in the meantime.

I tried flipping the order that I made the attachment (selecting the hair second I think) and that moved the hair from the feet to the head - but still not in the right position - it ended up behind the head, though at least at the right height. I got that idea from watching one of the physics tutorials, but I’m at a loss as to why the hair attaches with an offset. I know you can set an offset so that the attachment doesn’t actually have to overlap, but this happens even with that at 0, and I’d still expect the hair to attach at its original placement, not offset behind that original placement.

I’m certainly missing something, but I’m a little burned out on getting it to work as I’m about as close at the end of my efforts as I was at the start.

Yeah, to be honest, there is no Soft cloth export support at this time. You can import ‘Rigid Body’ physics (eg, like a box dropping) but not ‘Soft cloth’ physics. Plus, I’m hoping they can also support animated morph too in the future.

I’ve actually made a FeedTracker request on the Reallusion site asking for Soft Cloth Physic support (or even baked physics) just so they know there is a huge request for it. I’m guessing they are probably working on it, but I think it’s still early at this stage.

Hair and cloth physics exported to Omniverse - Feedback Tracker (reallusion.com)