Applying standalone binaries, stuck on login

Hi,

I run into login problem when applying nv standalone specific binaries (sudo ./apply_binaries.sh --target-overlay) and flashing the whole Xavier.

The boot was successful, creating user also but after I got to the login screen and after entering the password the login screen reappeared constantly. I’ve tried to configure lightdm but without any progress.

Applying nv specific as Debian packages is successful.

Tests:

  1. Flash after cleanly installed JP over SDK, OK
  2. Flash after applying binaries as Debian packages, OK
  3. Flash after applying binaries as standalone, ERR

L4T: 32.3.1
JP: 4.3

Hi d.kristofic,

Thanks for reporting this issue. We can reproduce this issue.
May I know any reason you need to use target-overlay instead of deftaul deb package method?

I don’t see document mentioned about target-overlay option here.

main use is as helper script after compiling custom kernel to apply custom modules and headers located in kernel. So there is no need to create and maintain our own script.

Could you pinpoint the problem in the script or some file must be replaced?

Hi,

Actually “–target-overlay” is only used for internal debug case. I cannot pinpoint the error immediately.
I would suggest to use other workaround at this moment until we fix this issue.

For example. you could directly put Image to Linux_for_Tegra/kernel/ and directly copy the module folder to rootfs.

Thanks for your patience.

1 Like

HI d.kristofic,

We just checked. To use the target-overlay, you need to use the clean rootfs instead of the one from jetpack. Because the jetpack would by default use the deb package during its first installation, it is not a clean one if you try with target-overlay again later.