Apt install cuda-profiler-api-11-4 failed

Hi,

Really thanks for this information.
We are checking this issue internally.

Thanks.

Hi,

The issue is fixed.
Please try the CUDA installation again.

Thanks.

Worked great! Thanks!

I am also getting this error.

This is on a fresh install with SDKManager on the ODIN. if you then do an apt upgrade, you get the following:

root@ubuntu:/home/aerium# apt-upgrade
bash: apt-upgrade: command not found
root@ubuntu:/home/aerium# apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
![Screenshot from 2022-06-28 12-15-33|690x388](upload://syaX34SfcDKW6QtP6byI0jiWXWc.jpeg)

You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 cuda-libraries-dev-11-4 : Depends: cuda-profiler-api-11-4 (>= 11.4.239) but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

also to note, the Ubuntu Software Updater also returns a broken status:
see uploaded file

also to note apt install is now no longer working because of this issue.

1 Like

This is probably going to be resolved by someone who is in control of the .deb packages. However, I have found a solution.

There was a similar issue on stack overflow for fixing an old cuda instillation on x86 I found a while back but lost the link :(

Try this:

sudo apt --fix-broken install -o Dpkg::Options::="--force-overwrite"
11 Likes

Hi, d.petkovsek
Thanks for this information.

Hi, bbullas
Please let us know if the issue remains after applying the fix-broken command.

Thanks.

thanks for your comment, it works !

not fixed for Xavier NX Dev Kit.

Hi, bob3u3p3

Could you share the log about the failure?
Thanks.

Yes the following command has fixed the issue :)

apt --fix-broken install -o Dpkg::Options::="--force-overwrite"
2 Likes

Steps:
Loaded new image and upgraded the OS to make sure it is up to date. Also removed clutter.
Loaded the CUDA utilities using SDKManager
executed sudo apt-upgrade.
Log File:
Script started on 2022-06-30 13:59:09-06:00 [TERM=“xterm-256color” TTY=“/dev/pts/0” COLUMNS=“108” LINES=“78”]
sudo apt update

0% [Working]e[0m

Hit:1 https://repo.download.nvidia.com/jetson/common r34.1 InRelease
Hit:2 Index of /ubuntu-ports focal InRelease
Hit:3 https://repo.download.nvidia.com/jetson/t194 r34.1 InRelease
Hit:4 Index of /ubuntu-ports focal-updates InRelease
Hit:5 Index of /ubuntu-ports focal-backports InRelease
Hit:6 Index of /ubuntu-ports focal-security InRelease

Reading package lists… Done
Reading state information… Done

6 packages can be upgraded. Run ‘apt list --upgradable’ to see them.
apt upgrade

Reading package lists… Done

Building dependency tree

Reading state information… Done

Calculating upgrade… Done

The following package was automatically installed and is no longer required:
cuda-nvprof-11-4
Use ‘sudo apt autoremove’ to remove it.
The following NEW packages will be installed:
cuda-profiler-api-11-4
The following packages will be upgraded:
cuda-command-line-tools-11-4 cuda-compiler-11-4 cuda-libraries-11-4 cuda-libraries-dev-11-4
cuda-toolkit-11-4 cuda-visual-tools-11-4
6 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 34.6 kB of archives.
After this operation, 90.1 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 https://repo.download.nvidia.com/jetson/common r34.1/main arm64 cuda-command-line-tools-11-4 arm64 11.4.14-1 [2,478 B]
Get:2 https://repo.download.nvidia.com/jetson/common r34.1/main arm64 cuda-compiler-11-4 arm64 11.4.14-1 [2,440 B]
Get:3 https://repo.download.nvidia.com/jetson/common r34.1/main arm64 cuda-libraries-11-4 arm64 11.4.14-1 [2,512 B]
Get:4 https://repo.download.nvidia.com/jetson/common r34.1/main arm64 cuda-profiler-api-11-4 arm64 11.4.239-1 [18.6 kB]
Get:5 https://repo.download.nvidia.com/jetson/common r34.1/main arm64 cuda-libraries-dev-11-4 arm64 11.4.14-1 [2,552 B]
Get:6 https://repo.download.nvidia.com/jetson/common r34.1/main arm64 cuda-toolkit-11-4 arm64 11.4.14-1 [3,204 B]
Get:7 https://repo.download.nvidia.com/jetson/common r34.1/main arm64 cuda-visual-tools-11-4 arm64 11.4.14-1 [2,856 B]
100% [Working]e[0m

Fetched 34.6 kB in 0s (92.5 kB/s)
debconf: delaying package configuration, since apt-utils is not installed

(Reading database … 100%
(Reading database … 159428 files and directories currently installed.)
Preparing to unpack …/0-cuda-command-line-tools-11-4_11.4.14-1_arm64.deb …
Unpacking cuda-command-line-tools-11-4 (11.4.14-1) over (11.4.14-1) …
Unpacking cuda-compiler-11-4 (11.4.14-1) over (11.4.14-1) …
Unpacking cuda-libraries-11-4 (11.4.14-1) over (11.4.14-1) …
Unpacking cuda-profiler-api-11-4 (11.4.239-1) …
e[1mdpkg:e[0m error processing archive /tmp/apt-dpkg-install-Dmtuud/3-cuda-profiler-api-11-4_11.4.239-1_arm64.deb (–unpack):
trying to overwrite ‘/usr/local/cuda-11.4/targets/aarch64-linux/include/cudaProfiler.h’, which is also in package cuda-nvprof-11-4 11.4.166-1
Unpacking cuda-libraries-dev-11-4 (11.4.14-1) over (11.4.14-1) …
Unpacking cuda-toolkit-11-4 (11.4.14-1) over (11.4.14-1) …
Unpacking cuda-visual-tools-11-4 (11.4.14-1) over (11.4.14-1) …
Errors were encountered while processing:
/tmp/apt-dpkg-install-Dmtuud/3-cuda-profiler-api-11-4_11.4.239-1_arm64.deb

Sub-process /usr/bin/dpkg returned an error code (1)e[0m
exit

Script done on 2022-06-30 14:00:11-06:00 [COMMAND_EXIT_CODE=“100”]

Also, apt update says all packages are up to date
apt upgrade returns this error:
bob@ubuntu:~/Desktop$ sudo apt upgrade

Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
cuda-libraries-dev-11-4 : Depends: cuda-profiler-api-11-4 (>= 11.4.239) but it is not installed
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).
bob@ubuntu:~/Desktop$ exit

–fix-broken install does not fix the error

Also, the update built into the OS reports the same error

Hi,

Seems some issues occur in the cache .deb file below:
Could you go to the folder and delete the package manually and try it again?

/tmp/apt-dpkg-install-Dmtuud/3-cuda-profiler-api-11-4_11.4.239-1_arm64.deb

Thanks.

file does not exist.
I deleted /usr/local/cuda-11.4/ to get rid of everything, and redownload, no help
bottom line, if I can’t run apt upgrade, I cannot install the packages I need.
IMHO this is the same problem described by bbullas, but I am trying to point out the root problem, which is the fact that the file write failure of :

Do you want to continue? [Y/n] y
debconf: delaying package configuration, since apt-utils is not installed
(Reading database … 159428 files and directories currently installed.)
Preparing to unpack …/cuda-profiler-api-11-4_11.4.239-1_arm64.deb …
Unpacking cuda-profiler-api-11-4 (11.4.239-1) …
dpkg: error processing archive /var/cache/apt/archives/cuda-profiler-api-11-4_11.4.239-1_arm64.deb (–unpa
ck):
trying to overwrite ‘/usr/local/cuda-11.4/targets/aarch64-linux/include/cudaProfiler.h’, which is also in
package cuda-nvprof-11-4 11.4.166-1
Errors were encountered while processing:
/var/cache/apt/archives/cuda-profiler-api-11-4_11.4.239-1_arm64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

1 Like

Yep, this one fixed it for me too: sudo apt --fix-broken install -o Dpkg::Options::="--force-overwrite".

I was getting the following error for a $ sudo apt --fix-broken install:

...
The following NEW packages will be installed:
  cuda-profiler-api-11-4
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
Need to get 0 B/18.6 kB of archives.
After this operation, 90.1 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
debconf: delaying package configuration, since apt-utils is not installed
(Reading database ... 161620 files and directories currently installed.)
Preparing to unpack .../cuda-profiler-api-11-4_11.4.239-1_arm64.deb ...
Unpacking cuda-profiler-api-11-4 (11.4.239-1) ...
dpkg: error processing archive /var/cache/apt/archives/cuda-profiler-api-11-4_11.4.239-1_arm64.deb (--un
pack):
 trying to overwrite '/usr/local/cuda-11.4/targets/aarch64-linux/include/cudaProfiler.h', which is also 
in package cuda-nvprof-11-4 11.4.166-1
Errors were encountered while processing:
 /var/cache/apt/archives/cuda-profiler-api-11-4_11.4.239-1_arm64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Thanks @d.petkovsek !

1 Like

Hi, bob3u3p3

It looks like the previous broken package still causes some errors in your environment.

Is reflashing an option for you?
If yes, could you give it a try?

Thanks.

sudo apt --fix-broken install -o Dpkg::Options::="--force-overwrite"

It works for me.

3 Likes

Thanks for the helpful fix!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.