Apt unmet dependencies on g++

I am trying to install build essential but I am fronting unmet dependency error

The following packages have unmet dependencies:
build-essential : Depends: g++ (>= 4:9.2) but it is not installable
I have already apt --fix-broken install but it did not help.
I am quite stuck at this what should I do?
Thank you always!

I don’t know; maybe something like:

I am curious, g++ 4 is very old. Maybe still used in older boot chain software. What is it which is in need of this? I know the cross compiler is still available, it is available in some of the older L4T releases.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.