Ar0144 camera error CORRECTABLE_ERR

I’m trying to interface an AR0144 camera. Can anyone give any insight into this error? It basically won’t stream and just hangs.

     kworker/0:4-4830  [000] ....    26.637762: rtcpu_nvcsi_intr: tstamp:1175837355 class:GLOBAL type:PHY_INTR0 phy:0 cil:0 st:0 vc:0 status:0x00000110
     kworker/0:4-4830  [000] ....    26.637762: rtcpu_nvcsi_intr: tstamp:1175839033 class:GLOBAL type:STREAM_VC phy:0 cil:0 st:0 vc:0 status:0x00000008
     kworker/0:4-4830  [000] ....    26.637762: rtcpu_nvcsi_intr: tstamp:1175839033 class:CORRECTABLE_ERR type:STREAM_VC phy:0 cil:0 st:0 vc:0 status:0x00000008

Check the TRM reg NVCSI_STREAM_0_INTR_STATUS_VC0_0 and NVCSI_PHY_0_CILA_INTR_0_STATUS_CILA_0, it’s could be the pixel clock incorrect in the dts.
Have boost the nvcsi/vi clocks to try. Also have a reference to below wiki for sensor bring up.

https://elinux.org/Jetson_TX2_Camera_BringUp

@ShaneCCC when I boosted the nvcsi/vi clocks according to your link it started working.

What does this tell me? Can I just always run with the clocks set like this or is there something wrong in my device tree settings?

You can increase the pixel_clk_hz in the device to get more bandwidth for your sensor.

1 Like

That did the trick. Thanks @ShaneCCC

@ShaneCCC sorry to revisit this. It turns out that increasing pixel_clk_hz proportionally reduces my frame rate. Is there anything else I can try that mimics or addresses boosting the nvcsi/vi clocks?

@ShaneCCC also, this is the only line I need to make things work but I’m not sure what it does
echo 1 > /sys/kernel/debug/bpmp/debug/clk/nvcsi/mrq_rate_locked

Add serdes_pix_clk_hz to device tree and define it bigger than pixel_clk_hz.

https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/camera_sensor_prog.html#wwpID0E0Q50HA

1 Like