ARCH= -gencode arch=compute for NX:

i am working on jetson Xavier NX box,
i updated to jetpack 5.0.1 and deepstream6.1 right now.
before i setup ARCH= -gencode arch=compute 72 for NX to train some models.
but i cmake another file yesterday it detected arch-gencode 75!
so i am confuse right now, should i setup 72 or 75 for jetson xavier nx when i trainning?

thank you very much!

Hi @wilicyy, Xavier is compute_72 / sm_72

Here is the deviceQuery output for Xavier NX:

$ ./deviceQuery
./deviceQuery Starting...

 CUDA Device Query (Runtime API) version (CUDART static linking)

Detected 1 CUDA Capable device(s)

Device 0: "Xavier"
  CUDA Driver Version / Runtime Version          10.2 / 10.2
  CUDA Capability Major/Minor version number:    7.2
  Total amount of global memory:                 7773 MBytes (8151035904 bytes)
  ( 6) Multiprocessors, ( 64) CUDA Cores/MP:     384 CUDA Cores
  GPU Max Clock rate:                            1109 MHz (1.11 GHz)
  Memory Clock rate:                             1109 Mhz
  Memory Bus Width:                              256-bit
  L2 Cache Size:                                 524288 bytes
  Maximum Texture Dimension Size (x,y,z)         1D=(131072), 2D=(131072, 65536), 3D=(16384, 16384, 16384)
  Maximum Layered 1D Texture Size, (num) layers  1D=(32768), 2048 layers
  Maximum Layered 2D Texture Size, (num) layers  2D=(32768, 32768), 2048 layers
  Total amount of constant memory:               65536 bytes
  Total amount of shared memory per block:       49152 bytes
  Total number of registers available per block: 65536
  Warp size:                                     32
  Maximum number of threads per multiprocessor:  2048
  Maximum number of threads per block:           1024
  Max dimension size of a thread block (x,y,z): (1024, 1024, 64)
  Max dimension size of a grid size    (x,y,z): (2147483647, 65535, 65535)
  Maximum memory pitch:                          2147483647 bytes
  Texture alignment:                             512 bytes
  Concurrent copy and kernel execution:          Yes with 1 copy engine(s)
  Run time limit on kernels:                     No
  Integrated GPU sharing Host Memory:            Yes
  Support host page-locked memory mapping:       Yes
  Alignment requirement for Surfaces:            Yes
  Device has ECC support:                        Disabled
  Device supports Unified Addressing (UVA):      Yes
  Device supports Compute Preemption:            Yes
  Supports Cooperative Kernel Launch:            Yes
  Supports MultiDevice Co-op Kernel Launch:      Yes
  Device PCI Domain ID / Bus ID / location ID:   0 / 0 / 0
  Compute Mode:
     < Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) >

deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 10.2, CUDA Runtime Version = 10.2, NumDevs = 1
Result = PASS

Perhaps the cmake file you ran wasn’t properly configured to detect the Jetson GPUs.

ok know now.

thank you very much!

i would like to ask a question about fan,
after i updated new jetpack 34.1.1, and fan is off.
how can i open it because my box works outdoor.

thank you

Hi @wilicyy, you can manually control the fan with jtop tool:

Or you can check the sysfs file that the jetson_clocks script uses to control your fan:


        if [ ! -w "${TARGET_PWM}" ]; then
                echo "Can't access Fan!"

        case "${ACTION}" in
                        echo "Fan: PWM=`cat ${TARGET_PWM}`"
                        store "${TARGET_PWM}"
                        store "${TEMP_CONTROL}"
                        if [ "${FAN_SPEED_OVERRIDE}" -eq "0" ]; then
                        if [ -w "${TEMP_CONTROL}" ]; then
                                echo "0" > "${TEMP_CONTROL}"
                        echo "${FAN_SPEED}" > "${TARGET_PWM}"

        if [ "${SOCFAMILY}" = "tegra194" -a "${machine}" = "Clara-AGX" ]; then

                if [ ! -w "${FPGA_TARGET_PWM}" ]; then
                        echo "Can't access Fan (FPGA)!"

                case "${ACTION}" in
                                echo "Fan (FPGA): PWM=`cat ${FPGA_TARGET_PWM}`"
                                store "${FPGA_TARGET_PWM}"
                                store "${FPGA_TEMP_CONTROL}"
                                if [ "${FAN_SPEED_OVERRIDE}" -eq "0" ]; then
                                if [ -w "${FPGA_TEMP_CONTROL}" ]; then
                                        echo "0" > "${FPGA_TEMP_CONTROL}"
                                echo "${FAN_SPEED}" > "${FPGA_TARGET_PWM}"

hi sir,
i do like jtop to control by easy way, but it shows like this and no way to open fan:

or could you advice a simple command to open fan??

thank you very much!

and i shows this after i exit jtop:

Aye sorry, actually I’m not sure if jtop has been updated or not by @rbonghi for JetPack 5.0 yet.

In the meantime you may want to just use the code from the jetson_clocks script if that works for you.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.