Arduino-cli on Tegra X1

Hello,

I was wondering if I can run arduino-cli on TX1?

I used this tutorial How To Program Arduino From The Raspberry Pi Command Line – Siytek that worked exactly the same up until I tried to upload the code to my arduino nano.

the code:
"
void setup() {
// initialize digital pin LED_BUILTIN as an output.
pinMode(LED_BUILTIN, OUTPUT);
}

// the loop function runs over and over again forever
void loop() {
digitalWrite(LED_BUILTIN, HIGH); // turn the LED on (HIGH is the voltage level)
delay(1000); // wait for a second
digitalWrite(LED_BUILTIN, LOW); // turn the LED off by making the voltage LOW
delay(1000); // wait for a second
}
"

This is >Example>Basic>Blink from arduino library, that I tested on my rasberry pi 4 before and worked.
On TX1 I get sync errors when I try uploading the code.

Solved:

It wasn’t an issue with TX1, it was the bootloader, I was using different arduino nano boards and so it happened that one board only works for upload with the new bootloader

Glad to know you resolved the problem, thanks for sharing.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.