Are custom levels unsupported?

Every time I try to load in a new level in the sim, it crashes, if not shortly after trying to add new objects into the level. Is there a way we are supposed to be able to make a new scene for the sim? I’ve tried launching in editor mode as well as using a different installation of unreal and importing the level into the sim with varying levels of success.

Hi RoboGuy,

Please walk me through your steps and give more details.

Thanks,
Liila

Thanks for getting back to me, I’ll try to describe the issue the best I can.

I installed following the documentation, and would start UE4 in Editor mode when editing levels, or start a sim with either carter or a custom sim, as described in the Isaac Sim documentation.

With a custom sim, starting with the warehouse map was fine, but if I tried to load a new level (using file>new level) other than the empty default one, it would crash. Once a level was loaded, attempting to create a blueprint, or moving an object into/around the scene would both cause a crash. Using carter sim, loading levels work better, but creating a blueprint, or starting a sim with a blueprint, still causes crashes.

Being in Editor mode would cause crashes whenever a blueprint was created, used, or in a level I tried to load. If I loaded in a blank level, moving an object around would also cause a crash eventually.

When I import a new level, I would either drag and drop the files into the IsaacSimProject content folder, or use the import button. Once the level was in the content browser, if I tried to load into it from the editor, or the command line, it would crash while loading if a blueprint was included in the level. If it did not have one, it would crash if I launched the sim, and tried to start the sim.

I uploaded the file generated by a crash here: https://drive.google.com/drive/folders/1N49pcIB2B8omjPweCtd1h6dxT5mU8o9d?usp=sharing

All I did for this one was start carter sim and try to add a blueprint to the warehouse level. UE4 crashed as soon as the blueprint window loaded in.