Are NVIDIA docker images available publicly ?

Hello everyone, I tried to install docker for OpenSeq2Seq, I got the same problem to pull: docker pull nvcr.io/nvidia/tensorflow:19.05-py3 on my second server, the first one doesn’t have any problem.

It takes so long to pull (around 15mins) and stop in the middle of download:
19.05-py3: Pulling from nvidia/tensorflow
7e6591854262: Pull complete
089d60cb4e0a: Pull complete
9c461696bc09: Pull complete
45085432511a: Pull complete
6ca460804a89: Pull complete
2631f04ebf64: Pull complete
86f56e03e071: Pull complete
234646620160: Downloading [==============================================> ] 577MB/615.2MB
7f717cd17058: Download complete
e69a2ba99832: Download complete
bc9bca17b13c: Download complete
1870788e477f: Download complete
603e0d586945: Download complete
717dfedf079c: Download complete
1035ef613bc7: Download complete
c5bd7559c3ad: Download complete
d82c679b8708: Download complete
059d4f560014: Download complete
f3f14cff44df: Download complete
96502bde320c: Download complete
bc5bb9379810: Download complete
e4d8bb046bc2: Download complete
4e2187010a7c: Download complete
9d62684b94c3: Download complete
e70e61e48991: Download complete
6620a817ff31: Download complete
874af72dc61e: Download complete
39de5b643317: Download complete
1ba764d61397: Download complete
6661cf4cb01b: Download complete
edfd5a4a5690: Downloading
c007f35ef1d7: Downloading
088703590f74: Downloading
ce44ec7dfdf6: Downloading
38b229b724c6: Downloading
ae80042374ee: Downloading
d9e75c987c5b: Downloading
2bf87e79bdd4: Downloading
42d6db33d410: Downloading
374065806c1d: Downloading
0a17aa5a6d01: Downloading
c4fe8023d353: Downloading
a2b88525ff9b: Downloading
594db2ac4bdc: Downloading
84944fffa3d0: Waiting
dada258c911f: Downloading
7dc07b277868: Waiting
7d88f3f3a4c0: Waiting
069f231543ba: Waiting
97e40d14d481: Waiting
943c51458298: Waiting
1ed7d48cdcc0: Waiting
0673b0e651a6: Waiting
2fc31867ba69: Waiting
53360fcab244: Waiting
unauthorized: authentication required

Is there anyone have same problem with me and would you please give me some keys?

Hi all,

I DID NOT log in before doing a docker pull as the previous posts suggest that there is no need to.

Tried to docker pull nvcr.io/nvidia/pytorch:19.06-py3 and had the same unauthorized: authentication required error. Below is the docker pull progress printout

19.06-py3: Pulling from nvidia/pytorch
9ff7e2e5f967: Pull complete
59856638ac9f: Pull complete
6f317d6d954b: Pull complete
a9dde5e2a643: Pull complete
694c3f4d804b: Pull complete
152db63595bc: Pull complete
cb3528edce39: Pull complete
41a1b2b47793: Downloading [===============================> ] 384.8MB/615.3MB
9451ec10bace: Download complete
b845e9780bc1: Download complete
3262938d0c4a: Download complete
de5d000be97c: Download complete
af8564be59ea: Download complete
8927afb6be7e: Download complete
caa2f310119f: Download complete
5048a89b3a01: Download complete
f7daecfa88b3: Download complete
4bb7bb278872: Download complete
4c2518a87078: Download complete
f69bed8109a2: Download complete
fb10aa9d1c31: Download complete
07507b602823: Download complete
49b53668c23e: Download complete
5dba2ac8ab21: Download complete
f0c80f71901f: Downloading [====================================> ] 193.7MB/263.1MB
b620572a1d92: Downloading
ff965a78092d: Waiting
dd69878b30f3: Waiting
08e71fb79a93: Waiting
0014fc2cbd3f: Waiting
af8f766cf56b: Waiting
1e9c8c1748aa: Waiting
96b95eebc8a5: Waiting
f84e1c5f2252: Waiting
5aa618fe592f: Waiting
5962ede25318: Waiting
58ce42a0fcba: Waiting
b2487c510741: Waiting
84cc11dcce95: Waiting
afbd0c24bbcb: Waiting
01a627535c1d: Waiting
17e8faf03d65: Waiting
4d6ec3e4fc76: Waiting
ad27722084d5: Waiting
c8394b897cb1: Waiting
7c954b84a68c: Waiting
ad255b4c2fa7: Waiting
2a2ca839a435: Waiting
b649bbfb8f3b: Waiting
772ca00a439e: Waiting
1ae3626b7967: Waiting
40bf6a24a59f: Waiting
89a2e8567e01: Waiting
701bfd3d73b3: Waiting
unauthorized: authentication required

any advice on how to fix the problem?

Also getting “unauthorized: authentication required” when trying to pull nvcr.io/nvidia/pytorch:19.06-py3. Previous tags worked just fine. Any update on this?

I tried today July 11 and was not able to reproduce the error:

% docker pull nvcr.io/nvidia/pytorch:19.06-py3 % docker rmi nvcr.io/nvidia/pytorch:19.06-py3 % docker logout nvcr.io % docker pull nvcr.io/nvidia/pytorch:19.06-py3

I tried to pull the exact image multiple times today, too. I tried it being logged in or out. I’m located behind a proxy and my internet connection is very spotty. I assume docker has difficulties resuming a download when there was not connection for say a minute or more. Have you tested against these cases? Is there a way to download the image another way, outside of docker, and give docker the pre-downloaded image manually? Thanks

I have faced the same issue, my problem solved by simply adding “sudo” before “docker login nvcr.io
and logged in

:)

I am trying to pull tensorflow container : docker pull nvcr.io/nvidia/tensorflow:19.10-py3

But I’m getting this error.

Error response from daemon: Get https://nvcr.io/v2/: x509: certificate is valid for FGT6HD3916806706, not nvcr.io

This only happens when I try to use this command by doing ssh into my DGX. But I’m able to pull the container directly on my DGX.

Please help me with the same.

Same issue here:

docker pull nvcr.io/nvidia/pytorch:20.02-py3

Error:

unauthorized: authentication required

UPDATE: It eventually worked, but took 2 attempts:

docker pull nvcr.io/nvidia/pytorch:20.02-py3
20.02-py3: Pulling from nvidia/pytorch
Digest: sha256:cc7a0505ffc2f8f58514a0b8983ade6f54d867befa4aa611995303db5b7bc1ab
Status: Image is up to date for nvcr.io/nvidia/pytorch:20.02-py3
nvcr.io/nvidia/pytorch:20.02-py3

Fwiw, I don’t need authentication and haven’t logged in. Please don’t change this. A login requirement would break my CI (and I suspect this is the case for many others).

Hi, I try to pull the image, but it is too slow, is the image.tar available somewhere so that I can download it and load the image in my server?
Thanks.