Argus Samples not running on TX1 with Leopard IMX274 cameras and OSVR attached

Hello all,

I am trying to run the Argus samples (e.g ‘argus_camera’ util) on a TX1 with IMX 274 CSI cameras (LeopardImaging company) AND OSVR attached, but the sample after printing a very long error report exit. I think the problem is the OSVR attached via the USB ports making the Argus to think it is a camera and fails to init it (only my wild guest…).

Has someone tried this configuration and encountered such a problem?

many thanks,


If you try “ls /dev/video*” did you see “/dev/video0” and “/dev/video1”? LI-IMX274 may have been enumerated as
“/dev/video1”. Have you tried “argus_camera -d /dev/video1”?

hello yahoo2016,

Thanks for the reply.

When trying ls /dev/video* i get: /dev/video0 /dev/video1 /dev/video2 /dev/video3.

When I diconnect the OSVR tracker I get only: /dev/video1 /dev/video2 /dev/video3.

I forgot to clear myself:
The argus camera will not work ONLY when the OSVR server is running. When the server is
not running - the argus camera application works.


How many LI-IMX274s or other cameras do you have? What camera adapter or carrier card are you using?

Have you tried “argu_camera -d /dev/videoX” for /dev/video1, /dev/video2 and dev/video3?

I have 3 LI-IMX274s cameras attached to adapter named LI-JTX1-MIPI-ADPT REV1.2.

and the OSVR tracker attached to a USB port.

Neither of argu_camera -d /dev/videoX (X = 1,2,3) works.

I can’t send you the errors printout (although a little bit long…)

Do you have their latest driver (e.g., 02/11/2017) for LI-JTX1-MIPI-ADPT?

I tried my LI-JTX1-MIPI-ADPT with LI-IMX274 and a USB web cam. The web cam showed as “/dev/video3”.

“argus_camera” worked for LI-IMX274 when the USB web cam was plugged in.

Can you dump the media device by media-ctl -p by web-cam present and not present to check the device node linke to usb or csi sensor.

Hi YossiW,

Have this issue been clarified and fixed?
Or please try the suggestion in last comments.


Hello kayccc,

I have bypassed the problem.

It seems that the OSVR server communicates on /Video0, disturbing
the IMX cameras and causing the app to exit immediatly on startup.
Since I am quite new to Linux, I did’t want to dig in the OSVR sources and trying to change
the server’s behavior, so I found that launching the OSVR server from my App AFTER the 3 cameras
are connected and running bypass the problem. In this situation, I get the 3 cameras frames + OSVR server’s readings (position and orientation).