Arrow shipped Orin has no US power cord

Received my Orin from Arrow this morning. I opened the package and pulled out the Orin and then the power brick and all is good. However, there are three powercords for the power brick (Type G (UK), Type E, and Type C) but no Type B needed for the US. Would not be a problem except the power brick uses a three pin clover leaf’ish like connector ( IEC 60320) instead of a standard IEC connector. Anyone else have the same issue or is my unit just an outlier?

I’m not sure if this is expected, will forward to internal team to comment. Thanks

My dev kits came with two identical US power cords and an Australian one.
Shipped to us from Arrow in the US.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

It sounds like you ordered 945-13730-0005-000*, i.e., the SKU5 devkit. That devkit would not include a cable with Type B plug. It should include these three power cables:

  • Type F (EU, KR, RU, RS, UA, VN)
  • Type G (UK, HK, SG, MY)
  • Type H (IL)

Probably you mistook F for E, but I’m not sure why you would identify one of the cables as type C, which is unearthed. That last cable should definitely have type H plug. If it was type C I’m not sure how it could have happened…

FYI, the SKU0 devkit ( 945-13730-0000-000) should include these three power cables:

  • Type B (US, CA, JP)
  • Type I (CN)
  • Type B (TW)

*Please reference the Jetson Part Number FAQ.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.