Artifacts after denoising (OptiX 6)

Hi,

In some cases small square areas of the image near the left border remain noisy.
It seems that the presence of these noisy areas is (probably) related to the resolution.

For example, running the optixDenoiser sample for 2000x1440:
optixDenoiser --nopbo --dim=2000x1440 --file result.ppm

gives this image which has artifacts.

This is with OptiX 6.0.0, GeForce RTX 2080 Ti, driver version: 430.64.

Hi @efounariotakis,

Which version of the CUDA toolkit are you using? Our denoiser engineer said he’s seen similar artifacts once before due to a CUDA incompatibility, and that the artifacts in that case were actually memory corruption.


David.

Hi David, the toolkit’s version is 10.0.

Hi, I just got around to trying to reproduce this, but I’m not seeing the same artifacts. I don’t have the same GPU, that could be it, but I am using an RTX GPU and a 430 driver. I note the modified camera angle, and I’m wondering if you made any other code changes to the optixDenoiserSample, or is the camera position the only thing?


David.

I only changed the camera so that given that specific resolution (2000x1440) there is geometry on the left edge of the image (where the artifacts appear). Another resolution that gives these artifacts for me is 2400x1800.

Hi, I was just wondering if you eventually reproduced this.

(If not is there something else I could try/test to help you with it?)

Hi, I’ve tried a few times and I haven’t been able to reproduce this. Are you able to see the artifacts while using the sample in interactive mode? You’re on Windows, right?

Things that you could try include updating to CUDA 10.1 and reproducing, upgrading to the latest driver to see if it’s fixed and/or downgrading your driver to an earlier one to see if the artifacts started recently, and reproducing on a 2nd machine if you have access to one.


David.

Hello again, yes I’m using Windows 10 (Enterprise 1803, Build 17134.885)

The artifacts are visible in interactive mode as well for the first few seconds (until the image clears).
Here’s a screenshot taken during interactive render (width=1360, height=836):
https://imgur.com/a/BsjYbG1

In both interactive and “offline” mode I use --nopbo, otherwise I get:
OptiX Error: ‘Unknown error (Details: Function “_rtBufferCreateFromGLBO” caught exception: Encountered a CUDA error: cuGLGetDevices returned (304): Operating system call failed)’

Here’s another screenshot with part of another render (not using the OptiX Samples) where the effect is stronger (GeForce RTX 2080):
https://imgur.com/a/FaGOs8u

I tried CUDA 10.1 and various drivers ranging from 419.09 to 431.36 but I encountered this every time.
I will let you know if something changes.