Ask for help (arv-viewer: ): Aravis-WARNING **: Failed to make stream thread high priority

I want to connect my gige camera to jetson nano and i build the aravis source files and it success, but i run the program and it shows that (arv-viewer): Aravis-WARNING **: Failed to make stream thread high priority. I don’t know how to slove this problem, if someone have solved this problem, please help me. Thank you.

Jetson nano

aravis 0.6

Camera description:

You’ll probably want to post this in the forum for your particular hardware, e.g., TX2, Xavier, Nano, so on. A short note though: Making a process higher priority requires root authority (in Ubuntu using “sudo”). Knowing how higher priority is being attempted could say if the program is just running as the wrong permission. Similarly, if there is an RT patch being employed, then perhaps you need to put the program in the right cgroup (see since RT priorities are controlled this way.

Thank you for your reply,i used to use “sudo”, but it didn’t work. I will try to figure out how higher priority is being attempted. Thank you.