ASR offline model not found on Jetson Orin

Using Jetson Orin NGX 64GB

Operating System - Ubuntu 20.04.5 LTS
Riva Version - arm64 v2.7.0

First I run bash and then I try running script from tutorial:
riva_asr_client --audio_file=/opt/riva/wav/en-US_sample.wav

I got follwing error:

Client output:

I1128 10:22:37.429924   420] Using Insecure Server Credentials
Loading eval dataset...
filename: /opt/riva/wav/en-US_sample.wav
Done loading 1 files
RPC failed: Error: Unavailable model requested. Lang: en-US, Type: offline
Done processing 1 responses
Some requests failed to complete properly, not printing performance stats

Server output:

I1128 10:22:37.434805   197] ASRService.Recognize called.
I1128 10:22:37.434899   197] Detected format: encoding = 1 numchannels = 1 samplerate = 16000 bitspersample = 16
I1128 10:22:37.434916   197] ASRService.Recognize performing streaming recognition with sequence id: 1905442010
E1128 10:22:37.434995   197] Error: Unavailable model requested. Lang: en-US, Type: offline

server-output.txt (10.4 KB) (9.7 KB)

I am not seeing any citrinet_256 RMIR file in model_repository. I’ve also tried default ASR conformer model but the output was the same. Somehow script which should initialize riva server do not download all required files.

Any ideas?

HI @tymonzar

Thanks for your interest in Riva,

Thanks for sharing the file,

I can see the offline model is present (uncommented)

I kindly request to try

  1. bash
  2. rerun bash
    And let me know whether it works,
    Also if still not working, please send docker logs riva-speech complete output as file in this thread


Hi @rvinobha,

thanks for contact - unfortunately it did not help. Here is the log:
I am also attaching full output after issuing bash (as riva-full-log.txt file)

riva-speech-logs.txt (1.6 KB)
riva-full-log.txt (88.0 KB)

Any updates on that issue?

Hi @tymonzar

Apologies, I will check with the team and provide updates


Hi @tymonzar

Offline Model is not packaged as prebuilt for embedded by default, Please fins the instruction below to add

  1. Open
  2. find models_asr and add the below highlighted change

After the change the code will look like below

Now your offline model will work after this addition


I believe you should add this info somewhere. The quick start instruction is not correct for that case.

Thanks @tymonzar for your feedback

This will be added as code in in upcoming version


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.