AssertionError: Config path must be a valid unix path. No file found at: /root/.docker/config.json. Did you run docker login?

Please provide the following information when requesting support.

• Hardware (T4/V100/Xavier/Nano/etc)
• Network Type (Detectnet_v2/Faster_rcnn/Yolo_v4/LPRnet/Mask_rcnn/Classification/etc) Classification_tf2
• TLT Version (Please run “tlt info --verbose” and share “docker_tag” here) 4.0.0-tf2.9.1
• Training spec file(If have, please share here) Default
• How to reproduce the issue ? (This is for errors. Please share the command line and the detailed log here.)

Initial setup using
wget --content-disposition -O

unzip -u -d ./getting_started_v4.0.1 && rm -rf && cd ./getting_started_v4.0.1

docker login done with API key.

Then to run the Jupyter notebook, launched a container with docker run -it --gpus all --name amogh_tao -p 8888:8888 -v /$PWD:/$PWD -v /var/run/docker.sock:/var/run/docker.sock -w /$PWD bash and launched Jupyter from within the container.

The classification_tf2 notebook installs NGC CLI and downloads the pre-trained model.

When I try to train from within the notebook, it says API key missing.

Looked up AssertionError: Config path must be a valid unix path. No file found at: /root/.docker/config.json. Did you run docker login? but that didn’t help

1 Like

Could you share the full command and full log? Thanks.

I have another issue related to that actually that popped up
While I was trying to fix this, I decided to try to log in to docker as user instead of root.
Since then, when I run the classification_tf2 notebook, the train command, it shows something like the following.

In the notebook when I try running the !tao train … command, it says that tao: command not found.

Suggest you to double check with the guide in TAO Toolkit Quick Start Guide - NVIDIA Docs, especially

  • setting up a python environment using miniconda
  • Install the CLI launcher via the quick start script
  • trigger notebook
  • etc

I was able to access the API key and log in I think

But since I am running the notebook and training command inside a docker, there’s another error.

Setup: Following is the command for starting my base docker container

Once inside the container, I open the jupyter notebook classification_tf2.ipynb and run the cells.

When I run the training command -
!tao classification_tf2 train -e $SPECS_DIR/spec.yaml
I get the following error -

I think when the training script tries launching a docker container while already being inside a docker container, there is this issue.

I read your comment and have followed the advice while running my docker container. Can you suggest what else can be done?

You are already running inside the container. In this case, please use command without “tao”.
! classification_tf2 train -e $SPECS_DIR/spec.yaml

BTW, you can also open a terminal instead of the jupyter notebook. And then run above command.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.