ASUS EB1037 - nvidia 820m - VBios issue - optimus (EFI/ACPI/CSM issue?)

I’ve already tried posting about this but it was “hidden” hopefully this post isn’t.

I’ve bought an ASUS EeeBox EB1037 thinking it would make a great HTPC.

After trying to install ubuntu I’ve discovered it is an nvidia optimus based system.

I’ve tried loads of different ways to get things working but I think the main issue comes down to ubuntu not being able to access the VBios.

When trying to boot from a LiveCD I have to add “nouveau.modeset=0” to the Linux grub command. That then boots fine. If I don’t do that and remove the quiet splash part it hangs at the VBios section.

To be able to boot all the time nouveau has to be blacklisted.

The hang looks like this with the Bios error

This is also true when using bumblebee

I get the following error with bumblebee and with OpenElec 4.0.7.

kernel: [ 2103.239018] vgaarb: this pci device is not a vga device
kernel: [ 2103.240424] nvidia 0000:01:00.0: irq 113 for MSI/MSI-X
kernel: [ 2103.247963] NVRM: failed to copy vbios to system memory.
kernel: [ 2103.249699] NVRM: RmInitAdapter failed! (0x30:0xffffffff:714)
kernel: [ 2103.249714] NVRM: rm_init_adapter failed for device bearing minor number 0

Any ideas how to get past this step so I can somehow try and get the nvidia graphics working?

Edit: I should add that I am using ubuntu 14.04. The things I had tried were various nvidia drivers (319, 331, 337, 340) with and without bumblebee. prime-switch and bbswitch fail and the issues all seem to be around the vbios problem.

I’ve tried a patch that relates to CSM/EFI issues but that didn’t help.

I’ve also tried various combinations of CSM/EFI settings, ACPI/PCI settings and Win8/Win7/Android/OtherOS settings in the BIOS/EFI.

Hopefully this has been unhidden now.

You have to blacklist nouveau anyway, because “nouveau” and “nvidia” do conflict. Both are kernel modules for nvidia cards, but while the first is the FLOSS kernel module included with the kernel, the second one is the proprietary module from nvidia.

In order to use the proprietary nvidia driver (which I assume you want to do, since you are posting here), you have to blacklist the nouveau module.
Actually, ubuntu should have done so when you installed the nvidia driver, but apparently it didn’t. So, please blacklist the module yourself, and than report back with your problem.

Sorry, I’ll try and be more clear.

“nouveau” is blacklisted so there isn’t a conflict between that and the official nvidia driver.

The reason I mentioned nouveau is that it seems to suffer from a similar vbios issue as the nvidia driver. It was blacklisted fine when required to be.

A clean install of ubuntu obviously doesn’t contain the nvidia driver and defaults to the nouveau driver. This causes ubuntu to hang on boot, when nouveau is blacklisted it boots fine. But my point is that it hangs with a vbios error. So neither the nouveau driver or the nvidia driver can access the vbios.

The issue looks very similar to this - https://devtalk.nvidia.com/default/topic/684651/linux/ux32vd-quot-failed-to-copy-vbios-to-system-memory-quot-yet-again/

Hi! I have this same problem with Asus EB1037 and ubuntu based linux mint 17. Reading Thomas posts I manage to get my pc to work at least with integrated gpu using “nouveau.modeset=0”.

I guess nobody has any ideas regarding this one?

I still have this problem. Thomas have you managed to figure out something new about this? Any feedback from nvidia guys would be awesome

Failing to copy the BIOS is usually a bug in the system’s BIOS. Is there a BIOS update available from the manufacturer?

Thomas is certainly not alone. I just checked and (If I’m reading this right) my EB1037 reports as having a newer BIOS version than what is on the asus.com support site!

Current downloadable BIOS on asus.com:

Version 0505
Description Firmware change
File Size
3,65 (MBytes) 2014.04.15 update

Yet the bios in my system reports:

BIOS Version: 0606 x64
Build Date: 05/28/2014

Aaron, I definitely understand that this may not be an Nvidia problem. I’m trying to assist with some detail in response to your question, while holding out hope that this is somehow resolved! So far the internet has dead-ended on this one with bumblebee, etc. Any help or guidance is definitely appreciated!

I’ve posted on the Asus forum but I doubt I’ll get any joy because they don’t even have an official EeeBox section.

Looks like I’ll sell mine if anyone is interested (!)

On this webpage http://us.download.nvidia.com/XFree8...nproblems.html I get the following details:

[i]Why does the VBIOS fail to load on my Optimus system?

On some notebooks with Optimus graphics, the NVIDIA driver may not be able to retrieve the Video BIOS due to interactions between the System BIOS and the Linux kernel’s ACPI subsystem. On affected notebooks, applications that require the GPU will fail, and messages like the following may appear in the system log:

NVRM: failed to copy vbios to system memory.
NVRM: RmInitAdapter failed! (0x30:0xffffffff:858)
NVRM: rm_init_adapter(0) failed

Such problems are typically beyond the control of the NVIDIA driver, which relies on proper cooperation of ACPI and the System BIOS to retrieve important information about the GPU, including the Video BIOS.[/i]

The issue seems to be the ACPI, does anyone knows any settings to change into the BIOS ?

Hi I’m also a proud owner of a EB1037.

I current running with the nvida disabled only using the intel grapichs.
Still i have issues with the system freezing from time to time.

I runned dmesg and could see that there is alot of error messages related to ACPI. So I have set the acpi=off in grub and now my system seems to be stable.

Seems to be a way to move forward for this issue, following this steps
https://wiki.ubuntu.com/DebuggingACPI

I have not got further than the apci=off step, i will keep it for a while to be 100% sure.
Is there anyone that is ahead of me tracking this down?

We are discussing about Ubuntu on EB1037 here:

http://ubuntuforums.org/showthread.php?t=2234341

Disable the “Power Technology” for CPU into the BIOS to solve the ACPI issues :

http://ubuntuforums.org/showthread.php?t=2234341&page=2&p=13238129#post13238129