Asus G20 with Nvidia GTX960: Trying to install Ubuntu 14.04 to do Cuda Development for Jetson TX1: H

I have had so much trouble trying to install Ubuntu on this PC that I am beginning to question whether or not it is possible (ref: https://rog.asus.com/forum/showthread.php?57264-Linux-on-G20).

So, I am asking a larger question:

Is there a recommended PC (hopefully that has a GTX in it, if possible), that can be used to install Cuda 7.x on so that I can build code for the Jetson TX1 (which needs a dedicated Linux PC to interface with, V-box Ubuntu on Windows won’t work).?

Or, a set of working instructions of how to get the existing system to work. I have tried all I have been able to find, but nothing seems to work. There are some nasty incompatibilities between UEFI/legacy and Gparted, etc.

Thanks,

-Glenn

Why does V-box Ubuntu not work?

Recover mode on the Jetson doesn’t work with Ubuntu running in V-box. Maybe it has to do with Ubuntu having to go through Windows for access to the USB port that programs the Jetson.

Linuxdev had this to say on this:
https://devtalk.nvidia.com/default/topic/935734/jetson-tx1-won-t-flash-not-entering-recovery-mode-won-t-boot-brick/
Many people have had issues running on a VM…it isn’t that it can’t work, but that there are a lot of little issues you may never see which actually break the flash. One is that the underlying file system must be a native Linux system, that NTFS will not do the job (NTFS cannot reproduce Linux permissions). Others are suprised to find the VM does not have enough disk space…you’ll probably want about 30GB of free space after everything is copied into the VM (I see “tar: write error”). Sometimes there are issues related to ownership of the USB port on the VM host. The list goes on.
#2
Posted 05/13/2016 06:42 PM

[Solved] - I was able to successfully install Ubuntu 14.04.4 “Server” on the Asus G20 with no problem at all.