Asus GTX 1050ti problems

Hi,

I tried many thing to make work Asus 1050ti on my HPE MicroServer Gen10. I suspect the card is bad.

Here’s a summary that I tried.

First, if I connect the HDMI on a monitor, it doesn’t work. I had to use the default VGA on the server.

I tried installing Proxmox with VM Passthrough, and with LXC Passthrough, using many install help that I found on Google.

I tried installing VMware 6.7 and 6.5u3 with passthrough.

Last thing, I tried installing Ubuntu Server 18.04LTS.

Driver is always load, using “NVIDIA-Linux-x86_64-440.31.run” file, or using the system package.

With all my installs, with the drivers installed, I always got this error:

[ 3108.376513] NVRM: GPU 0000:03:00.0: RmInitAdapter failed! (0x26:0xffff:1227)
[ 3108.376578] NVRM: GPU 0000:03:00.0: rm_init_adapter failed, device minor number 0

nvidia-smi on all installs

No devices were found

lspci:

03:00.0 VGA compatible controller: NVIDIA Corporation GP107 [GeForce GTX 1050 Ti] (rev a1)
03:00.1 Audio device: NVIDIA Corporation GP107GL High Definition Audio Controller (rev a1)

lsmod |grep nvidia

nvidia_uvm            929792  0
nvidia_drm             45056  0
nvidia_modeset       1105920  1 nvidia_drm
nvidia              19886080  2 nvidia_uvm,nvidia_modeset
drm_kms_helper        172032  2 amdgpu,nvidia_drm
ipmi_msghandler        53248  2 ipmi_devintf,nvidia
drm                   401408  5 drm_kms_helper,amdgpu,nvidia_drm,ttm

dmesg | grep NVRM

[    4.035487] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  440.26  Sun Oct 13 18:00:57 UTC 2019
[    7.822993] NVRM: GPU 0000:03:00.0: RmInitAdapter failed! (0x26:0xffff:1227)
[    7.823072] NVRM: GPU 0000:03:00.0: rm_init_adapter failed, device minor number 0

dpkg -l |grep nvidia

ii  libnvidia-cfg1-440:amd64              440.26-0ubuntu0~gpu18.04.2                  amd64        NVIDIA binary OpenGL/GLX configuration library
ii  libnvidia-compute-440:amd64           440.26-0ubuntu0~gpu18.04.2                  amd64        NVIDIA libcompute package
ii  nvidia-compute-utils-440              440.26-0ubuntu0~gpu18.04.2                  amd64        NVIDIA compute utilities
ii  nvidia-dkms-440                       440.26-0ubuntu0~gpu18.04.2                  amd64        NVIDIA DKMS package
ii  nvidia-headless-440                   440.26-0ubuntu0~gpu18.04.2                  amd64        NVIDIA headless metapackage
ii  nvidia-headless-no-dkms-440           440.26-0ubuntu0~gpu18.04.2                  amd64        NVIDIA headless metapackage - no DKMS
ii  nvidia-kernel-common-440              440.26-0ubuntu0~gpu18.04.2                  amd64        Shared files used with the kernel module
ii  nvidia-kernel-source-440              440.26-0ubuntu0~gpu18.04.2                  amd64        NVIDIA kernel source package
ii  nvidia-prime                          0.8.8.2                                     all          Tools to enable NVIDIA's Prime
ii  nvidia-utils-440                      440.26-0ubuntu0~gpu18.04.2                  amd64        NVIDIA driver support binaries

nvidia-bug-report.log.gz (355 KB)

With passthrough, you have to hide the hypervisor from the vm for the driver to work. Check for the vmware options.

Exactly what I did. I added “hypervisor.cpuid.v0 = FALSE” but still, nvidia-smi didn’t see it, and there was the same error (RmInitAdapter failed) on DMESG using Debian 10.

Did you try getting it to work on bare metal? If the same issue persists on that, try reseating the card in the pcie slot, check it in another system, then RMA.

All the tests and results in the quotes were done using Ubuntu 18.04LTS bare metal. I tried it after Proxmox and VMware gave me big headache…

I cannot try it in another PCIe slot because MicroServer just have 2 PCIe, and 1 is hide because the card is large.

I don’t have another system. I just open a RMA with the store where I bought it. I should be able to ship it tomorrow.

Thanks for your answers.