Asus ROG zepharus G15 1660TI max Q driver problem to ubuntu 18.04 bionic

HI there,

I got my laptop recently and it includes nvidia 1660ti max q and amd inbuilt drivers. i am struggling to install the nvidia driver to ubuntu 18.04 bionic.

I install drivers trough software & updates -> additional drivers.

![Screenshot from 2020-05-02 11-18-09|690x177](upload://bXhlGSQMKrkr25K6w3kRSkJYNAb.png) 

i upgrade my kernel already.

uname -r
5.3.0-51-generic

Here is my nvidia-smi result.

But when i try to enter nvidia-settings, it gives me an error as follows,

When i try, sudo prime-select nvidia, it already give me nvidia is already set. then i try to run nvidia-xconfig. When i try to run in super user it create xorg.conf file and then when i reboot, my loading screen freezes and i cannot get inside. so i removed that file for now.

I found some conf files over following path.

/usr/share/X11/xorg.conf.d$ ll
total 32
drwxr-xr-x 2 root root 4096 พ.ค. 1 11:58 ./
drwxr-xr-x 5 root root 4096 ก.พ. 4 01:25 …/
-rw-r–r-- 1 root root 92 ต.ค. 17 2019 10-amdgpu.conf
-rw-r–r-- 1 root root 206 ก.พ. 7 22:56 10-nvidia.conf
-rw-r–r-- 1 root root 1350 ธ.ค. 18 15:15 10-quirks.conf
-rw-r–r-- 1 root root 92 ต.ค. 17 2019 10-radeon.conf
-rw-r–r-- 1 root root 945 พ.ย. 28 2018 40-libinput.conf
-rw-r–r-- 1 root root 3025 พ.ย. 28 2018 70-wacom.conf

when tried to modify the 10-nvidia.conf into primary gpu “yes”, the next reboot freezes my booting screen too.

Also, i followed alot of forums, but still i could not solved this problem. Also, when i checked the glxinfo, it gives me following results.

glxinfo|egrep “OpenGL vendor|OpenGL renderer”
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 9.0, 128 bits)

Here is my log file of gpu-manager.log

cat /var/log/gpu-manager.log
log_file: /var/log/gpu-manager.log
last_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
new_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
can’t access /opt/amdgpu-pro/bin/amdgpu-pro-px
Looking for nvidia modules in /lib/modules/5.3.0-51-generic/updates/dkms
Found nvidia module: nvidia-uvm.ko
Looking for amdgpu modules in /lib/modules/5.3.0-51-generic/updates/dkms
Is nvidia loaded? yes
Was nvidia unloaded? no
Is nvidia blacklisted? no
Is intel loaded? no
Is radeon loaded? no
Is radeon blacklisted? no
Is amdgpu loaded? no
Is amdgpu blacklisted? no
Is amdgpu versioned? no
Is amdgpu pro stack? no
Is nouveau loaded? no
Is nouveau blacklisted? yes
Is nvidia kernel module available? yes
Is amdgpu kernel module available? no
Vendor/Device Id: 10de:2191
BusID “PCI:1@0:0:0”
Is boot vga? no
Vendor/Device Id: 1002:1636
BusID “PCI:6@0:0:0”
Is boot vga? yes
Error: can’t access /sys/bus/pci/devices/0000:06:00.0/driver
The device is not bound to any driver.
Skipping “/dev/dri/card0”, driven by “nvidia-drm”
Skipping “/dev/dri/card0”, driven by “nvidia-drm”
Skipping “/dev/dri/card0”, driven by “nvidia-drm”
Skipping “/dev/dri/card0”, driven by “nvidia-drm”
Does it require offloading? no
last cards number = 2
Has amd? yes
Has intel? no
Has nvidia? yes
How many cards? 2
Has the system changed? No
Unsupported discrete card vendor: 10de
Nothing to do

I blacked list every nouveau drivers already. Please help. I have attached my nvidia-bug-report.sh log file following. Please check it.

nvidia-bug-report.sh

Thank you.