AttributeError: module 'pyds' has no attribute 'gst_buffer_get_nvds_batch_meta' SYNC_IOC_FENCE_INFO

• Hardware Platform (Jetson / GPU)
Jetson Xavier NX
• DeepStream Version
DeepStream 6.0
• JetPack Version (valid for Jetson only)
4.6.1-b110
• TensorRT Version
8.2.1.8

I am trying to run deepstream by python. To install, I follow this instruction. Initially, it returned

No module named ‘pyds’

so I installed by

pip3 install pyds

Afterwards, I got this error when I ran deepstream_test_1_usb.py(deepstream_python_apps/deepstream_test_1_usb.py at master · NVIDIA-AI-IOT/deepstream_python_apps · GitHub):
AttributeError: module ‘pyds’ has no attribute ‘gst_buffer_get_nvds_batch_meta’ SYNC_IOC_FENCE_INFO ioctl failed with 9 0:01:39.756706843 15773 0x3e7a3b20 ERROR nvvideoconvert gstnvvideoconvert.c:3488:gst_nvvideoconvert_transform: buffer transform failed

It seems very similar to this topic, but the version of deepstream is different.

I searched the solution but I couldn’t find… How could I solve this?
Thank you in advance for your support.

Please follow this to compile and install deepstream python bindings.

1 Like

@Amycao thank you very much. I tried the instruction and I got

pyds-1.1.1-py3-none-linux_x86_64.whl is not a supported wheel on this platform

at step 4.1… Is there any specific version of whl for jetpack 4.6.1?

pyds-1.1.1-py3-none-linux_x86_64.whl

Please build with aarch64.

1 Like

@Amycao thank you very much for your kindness. I got through this problem!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.