Audio stop working in Jetson Nano after enbaling RTC

We have a third-party carrier board for which we recently add the RTC. Everything seems to work fine but the audio does not work.

I tried my best to understand this conversation but could not make it, I am a novice in understanding the DTB file.

I am attaching the DTS file for our DTB file, Please help me to resolve the issue.
dtb.txt (329.0 KB)

Hi @sarodeanil35,

I have couple of questions.

  • Which JP version are you using on Jetson Nano?
  • How are you checking Audio on 40 pin HDR?
  • Have you done pinmux settings to enable Audio via 40pin HDR? Kindly read through/follow instructions provided in the Developer Guide for the specific JP release. Jetson Software Documentation - Section " 40-pin GPIO Expansion Header"

Thanks,
Sharad

Hi @sharadg

Thanks for your response.

JP version :

Package: nvidia-jetpack
Version: 4.6.5-b29

# R32 (release), REVISION: 7.5, GCID: 36557527, BOARD: t210ref, EABI: aarch64, DATE: Tue Jun 11 23:12:44 UTC 2024

Audio checking:

I2S4 PINs
7 - AUDIO_MCLK
12 - I2S_4_SCLK
35 - I2S_4_LRCK
38 - I2S_4_SDIN
40 - I2S_4_SDOUT

Please check above.

Are you probing I2S signals or connecting Audio Codec to it? Please follow instructions provided in the link above to enable Audio via 40 pin HDR.

@sharadg

I am using the follwing commnad

sudo /opt/nvidia/jetson-io/jetson-io.py

I get the following

But dev kit I got the following

Is there anything wrong, if so can you guide me to correct it?