Audio2Face does not work with "special" symbols in Windows username


I was ‘opportunistic’ enough to use my real name when I created my Windows user account, and decided to go with the “special” letter that is part of my legal name. In 2019 I thought this should be fine, by now, it was 2019 after all. I regret my decision on a weekly/monthly basis with Windows applications that seemingly assume usernames should follow the 1977 ASCII standard. This unfortunately seems to include Audio2face.

OS: Windows 10 Pro Version 20H2 (19042.985)
OS System-locale: en-US / English (United States)
Hardware: AMD 5800X, RTX3080, Studio Driver 462.59
Software: Omniverse 1.1.4, Audio2Face 2021.2.4

I installed Omniverse to it’s default directory.
I then installed A2F also in it’s default directory.
I also enabled caching.
A2F did not launch using the “LAUNCH” button in the Omniverse application.
I uninstalled the Omniverse application.
I then changed the Omniverse settings folders to folders without any “special” symbols.
I reinstalled the Omniverse application.
A2F still did not launch using the “LAUNCH” button in the Omniverse application.
I launched A2F through the command line using the bat file.
This launched the application and first time setup.
The application gave various warnings and errors, ultimately failing to build the TensorRT model.

These are the most relevant warnings and errors from the log (supporting my non-latin issue assumption):

2021-05-27 00:04:55 [11,972ms] [Warning] [carb] Unable to open file ‘C:/Users/ArsΦne/.nvidia-omniverse/config/Cache/Omniverse.toml’ {errno = 22}

2021-05-27 00:04:55 [11,972ms] [Warning] [omni.ext-live.plugin] Unable to detect Omniverse Cache Server. File C:/Users/ArsΦne/.nvidia-omniverse/config/Cache/Omniverse.toml is not found. Consider installing it (version >= 280) for better IO performance.

2021-05-27 00:07:07 [143,826ms] [Error] [carb.python] [omni.audio2face.core] Unable to build TensorRT model

2021-05-27 00:07:07 [143,848ms] [Error] [carb.python] [omni.audio2face.core] Unable to build and/or load network: e:\omniverse\lib\audio2face-2021.2.4\exts\omni.audio2face.core_deps\deps\audio2face-nets\nets\male_hi_v1

2021-05-27 00:07:07 [143,848ms] [Error] [carb.python] [omni.audio2face.core] Error during running command: [‘e:\omniverse\lib\audio2face-2021.2.4\kit\python\lib\…/python’, ‘e:\omniverse\lib\audio2face-2021.2.4\exts\omni.audio2face.core\omni\audio2face\core\scripts\’, ‘{“deps_root”: “e:\\omniverse\\lib\\audio2face-2021.2.4\\exts\\omni.audio2face.core_deps\\deps”, “trt_model_fpath”: “C:\\Users\\Ars\u00e8ne\\AppData\\Local\\ov\\cache\\Kit\\101.0\\d34aba4f\\audio2face-nets\\male_hi_v1\\model_0.trt”, “input_model_fpath”: “e:\\omniverse\\lib\\audio2face-2021.2.4\\exts\\omni.audio2face.core_deps\\deps\\audio2face-nets\\nets\\male_hi_v1\\model.onnx”, “optimizer_params”: {“device_id”: 0, “use_fp16”: false}}’]

My username is incorrectly referenced as “ArsΦne” in the first 2 warnings. In the last error it’s referenced as “Ars\u00e8ne”. It should be “Arsène”.

If I can help any further, please let me know.

Thanks for your time.

One solution that might work is install it somewhere else.

Change to like c:\ov\audio2face\ or c:\launcher\audio2face\ or anything similar. So you don’t have to worry about the symbol. we have not try this but it may work.

You can do this in the Launcher settings to change were data are stored. Then all apps will be installed there. Let us know if that would work.

We have looked into the issue and we think we found the problem. We have a new patch coming out 2021.2.5 any day now. We should be able to fix this in 2021.2.6 shortly following the next patch. Thanks for bringing this up and appreciate the information.

Hi Siyuen, thanks for your message.

Since simply reinstalling Audio2Face in a different folder did not work, perhaps since the Omniverse application itself was still in a “non-safe” path, I uninstalled everything.

I uninstalled Audio2Face, Cache, Omniverse itself and then remove all remaining residual files in Windows.

Then I installed everything in a safe path, installed the cache and Audio2Face, and now everything works fine.

1 Like

Great to hear!