Autocruise can't upgrade Aurix

Hi All,

I am trying to flash Autocruise under ubuntu16.04 with latest driveworks Driveinstall It failed to flash the firmware. Later, I tried to upgrade the Aurix under Windows. According to the instructions for upgrading Aurix under windows, I set the corresponding COM port (one of the 4 USB to serial ports) with the specified requirement, such as Minimum Read Timeoust(msec) as 100. However, I still can’t upgrade the Aurix. When the screen shows “Now please power on the Drive PX board”, nothing will continue later. It stuck there. I can enter Tegra with setting the corresponding COM port as required through PUTTY.

Any kind advice to fix this issue? I appreciate your great helps!

Dear ray.di,

Could you please check if you remove all USB devices from DPX2? Thanks.

Hi Steve,

Thanks for your kind helps! I just followed your instruction and tried to upgrade the Aurix. However, it failed again. I removed all external connections to the PX2 AutoCruise. Finally, the network cable was connected to the PX2, and the USB debug cable was connected to the PX2. I set the ASC bootloader to PRG (NOT RUN). I correctly reconfigured the COM port with the specified baud rate (115200). When I use PUTTY to debug the COM port (COM5), found that the Tegra section is OK. I can see the contents of Tegra. However, when I try to use other COM port (COM6) to test the Aurix version, it said that the “command not found”. There are 4 COM ports in total.

We are Singulato Inc. Our address is: 2045 Martin Ave Ste 201, Santa Clara, CA 95050. We are very close to Nvidia. Can we have chance to upgrade this AutoCruise to AutoChaffeur? Or can someone help repair this AutoCruise? It may have some hardware issues. Thanks. I appreciate your great helps!

Dear ray.di,

Could you file a bug for your topic with detail description? We will look into it.
Please login to with your credentials. Please check MyAccount->MyBugs->Submit a new bug to file bug.
Please share ID here to follow up. Thanks.

Thanks. I just created one bug report under MyBugs topic in my account. Hopefully it will be closed soon.

Dear ray.di,

Thank you for your update.
Can I get the bug number you created? Thanks.

Thanks Steve. The bug ID is 2136127.

Hi Steve, Can we have chance to replace it with a new one? Or can anybody at Nvidia Santa Clara help replace the old SDK with the latest version? If possible, I can bring it to Nvidia. We are very close. Thanks

Dear ray.di,

Did you try to connect ethernet for OTA for Aurix FW update?
If not, could you please try it and check the process via minicom terminal? Thanks.

Hi Steve, I can’t detect the USB port under Ubuntu 16.04 when I connect the Autocruise with my desktop (work server). But I can detect the COM ports under windows when connecting Autocruise with windows machine. How to solve the issue that the USB ports can’t be detected when connecting Autocruise to Ubuntu16.04? Thanks

Dear ray.di,

We are finding out how to solve this issue. Thanks.

Hi Steve, we need one engineer from Nvidia to flash it directly. We can’t detect the USB port under Ubuntu 16.04. Only the engineer from Nvidia can help solve it. Thanks