Autofs on Jetson TK1 (r19)?

I’m wanting to use autofs on my Jetson TK1. I have installed the autofs package but it looks like it might be missing kernel support. Does the Jetson TK1 L4T r19 3.10.24 support autofs?
If not are there instructions available on how to add the autofs kernel module?

Thanks,

Generally speaking, Jetson supports everything Linux supports. autofs setup on L4T/Jetson matches that of any other Ubuntu Linux (L4T is Ubuntu with Jetson hardware support). Like many packages, autofs requires significant configuration, which goes beyond kernel driver+userland apps.

One of those steps is indeed adding a kernel module (you don’t need to flash or build an entire kernel). In the .config the item is “CONFIG_AUTOFS4_FS”. Other threads talk about adding modules. If those threads leave questions on adding a kernel module you can add your questions to those threads and someone will answer. FYI, these Ubuntu docs usually apply (boot loader differs; architecture is ARM hard float convention when listed):
https://help.ubuntu.com/14.04/index.html

Unfortunately my attempts at building the kernel fail with errors related to drivers/clocksource/tegra-nvtimers.c so I’m not able to generate the autofs module.

Most of the time (not always) build error solutions are just a matter of matching the working kernel configuration prior to updating for the new module. Building directly on Jetson also saves the day when cross compile tool chains become an issue. When this isn’t enough a bug fix should be available quickly, but only if details are reported.

Did you start with the /proc/config.gz for configuration? Was the compile directly on Jetson? Can you post the error?

Greetings,

I did not use /proc/config.gz. Doing so enabled my compile to complete successfully, thank you.
After setting CONFIG_AUTOFS4_FS=y I was expecting an autofs[4].ko module however this was not found. I assume that the autofs driver is built within the new kernel. Is there a way to verify this? To use the new kernel do I finish with make modules_install && make install?

Thanks,

“=y” means built-in, “=m” means module. I don’t know how to check that on a running system.

Supported file systems are in /proc/filesystems but I’m not sure if “autofs” is such.

Using =m did create the autofs4.ko module that I was interested in, good to know.
Used insmod to load the module and now autofs+ldap is working.
Thanks for the helpful hints.

With integrated autofs you’d have to actually try the feature or go looking at symbol files. You’d also have to install the entire kernel (and every module associated with a new kernel), and of course lsmod only shows modules, not integrated features.

Are you using “make menuconfig” to do your update to autofs? Does the “m” key set it to module, versus “y” setting it to “=y”? If so you could just install modules and be done with it from the kernel side. Beware that if you compile modules they won’t be correctly found unless you set the “localversion” to match the existing build (running “uname -r” shows something like “3.10.40-abcdef”, where “-abcdef” is the localversion, including the hyphen).

I tried make menuconfig but using vi seemed more direct to set CONFIG_AUTOFS4_FS=m.
Follow your suggestion I also set LOCALVERSION.
Followed this with make modules_install and modprobe autofs4 and added autofs4 to /etc/modules.
It looks like everything has worked as I was hoping.
Thanks,

Glad it worked. FYI, I’d use vi more on config too if it weren’t for some features not being available as a module…and even when it is available as a module, using menuconfig will automatically set up prerequisite features sometimes required for the module.

What I find lacking in menuconfig is the ability to search for the plain english description corresponding to the CONFIG_ symbol. Or for that matter, just searching for key words.