Auvidea J100 + Jetson TX2 USB Issue

Hi,

I’m trying to connect a usb mouse and keyboard to my Auvidea J100. I followed the instructions in the readme that comes from Auvidea’s firmware page after downloading (https://auvidea.com/firmware/) - which entails copying over the specific files and then reflashing the jetson tx2.

For some reason, even after I plug in my usb mouse and keyboard to the usb hub that’s connected to the j100 (via a converter cable), it’s still not working properly. I have the setup connected to a monitor so that part is working - but I can’t interface with it because the mouse and keyboard aren’t working.

I looked at other forum posts and tried a few of the approaches but none of them worked/people mentioned that they have one of the ports working. Is there anything else I should do other than download the latest firmware on the website?

The instructions in the readme.txt file don’t seem to be that detailed (as faced my other posters) so does anyone who had success with getting a mouse and keyboard working on the J100 have any solutions?

Thanks so much!

If you can connect via ssh or serial console you can monitor “dmesg --follow” while plugging/unplugging the devices to see what shows up. Also you can run “lsusb” and “lsusb -t”. This might show something.

Do note that the Auvidea boards require a different set of software be flashed, so if you have a Jetson which was originally mounted on a dev board you’ll need to flash it.

  1. what is output of the following ?
uname -a
  1. you may try usb hub with external power