Avoid blinking in deepstream dispaly when the interval for the detector is not 0

To alleviate the processing of my deepstream application, I set the interval of the detector to 1. After processing one frame, the processor will skip one frame and process the next.
The problem is that the display of the bounding boxes is blinking which is not easy for the eyes. Is there any method to keep the bounding boxes drawings the same as the previous when the current frame is not processed?

This is my setup:

  • NVIDIA Jetson Xavier NX (Developer Kit Version)
    • Jetpack UNKNOWN [L4T 32.4.4]
    • NV Power Mode: MODE_15W_6CORE - Type: 2
    • jetson_stats.service: active
  • Libraries:
    • CUDA: 10.2.89
    • cuDNN:
    • TensorRT:
    • Visionworks:
    • OpenCV: 4.1.1 compiled CUDA: NO
    • VPI: 0.4.4
    • Vulkan: 1.2.70

You could use the nvtracker element. It provides several algorithms for tracking or you could probably write your own plugin to just duplicate the boxes, if the built-in options don’t suit your needs.

Thanks for your reply, how to use the nvtracker for this purpose?

Include nvtracker after nvinfer and before nvosd. Your deepstream installation folder should have examples for a configuration file for nvtracker.

1 Like