AWS CloudXR Autolaunch without login

Hi, I have an AWS AMI built off of the cloudXR AMI with the expectation that when we launch, I can run a user-data script to launch the steamvr. However, even though steamvr is running with cloudXR I cannot connect to the instance until I manually log in, stop the process and rerun it. Is there something I am missing like a kiosk mode user needs to be enabled that auto logs on to the provisioned sever?

Hi @kunal2xl07 – If you’re using the AMI then DCV is automatically installed on the image. The only thing I can think of is that DCV has a default configuration that requires you to log into it in order to enable the display adapter on the instance. There’s a Windows registry flag that if set allows the instance to remain logged in after users disconnect/are not connected. Give this a shot and see if it works:

Yeah that does work, but it still requires a manual login. To deploy this at scale we’d want to be able to provision 10-20 servers at once just before they are needed and have users directly connect to those servers

Which process are you stopping and starting? Steamvr? As long as SteamVR runs, that’s all CloudXR needs to start streaming. Have you tried using something else besides DCV like VNC or PCoIP (don’t use RDP)? This seems more like an issue with the display driver access on system load. Others have been able to operate and scale servers without the initial user login you’re seeing, but not sure if they’re using user-data on the instance or if they’re doing something on the OS on boot.

Actually, RDP works. I have not tried other options yet but i don’t think that will help solving this issue. So before i had the server start steamVR on boot which launched as a process owned by system. I was not able to connect to the instance.
The other issue I immediately noticed was the missing cloudXRServerOptions file from appdata.

So this is what i have done since then:

  1. Setup the administrator user to autologon at boot,
  2. Set a custom app (that launches SteamVR then queries the mapfile.
  3. Once the headset connects then we launch our app.
    Even in that case our server options were missing…
    I am trying out setting up the instance after launch now and hopefully it works.

Okay i figured it out.

  1. Set autologon to the main admin account
  2. Make the following directory:
    The cloudXR folder is not present until steamVR is run at least once so the server options cannot be predefined until you create that directory. (maybe this should be added to the documentation)
  3. Copy your server options
  4. Start steamVR

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.